Motorola Lapdock HDMI Does Not Work with 0620 Angstrom Image--Works with 0508 image.

After days of trying to update to the 0620 image (BBB-eMMC-flasher-2013.06.20.img) on the BBB without success, it appears that the issue is that HDMI support changed after the 0508 image (BBB-eMMC-flasher-2013.05.08.img).and that the HDMI display on the Motorola Lapdock no longer works.

Since the Lapdock is a popular display/keyboard/trackpad/USB hub for the BBB (as well as for the Raspberry Pi) this is really too bad. Several others have mentioned this specific issue but no one seems to have figured out how to get the Lapdock HDMI to work on newer Angstrom releases, or what was changed that broke HDMI functionality on the Lapdock between the 0508 and 0620 releases.

For Micro-SD card images, Angstrom-Cloud9-IDE-GNOME-eglibc-ipk-v2012.12-beaglebone-2013.05.28.img works, but Angstrom-Cloud9-IDE-GNOME-eglibc-ipk-v2012.12-beaglebone-2013.06.06.img and Angstrom-Cloud9-IDE-GNOME-eglibc-ipk-v2012.12-beaglebone-2013.06.20.img do not work.

Yes, we know it does not work on the latest image. There are some fixes coming, based on when the SW team delivers them, that is expected to resolve the issue. It has to do with the DRM driver unable to create the correct timings on the latest version.


It would be helpful if on , and, there was a note that explained that the 0620 image doesn’t work on the Lapdock and to use the 0508 image for now. I’m sure that I’m not the only person that has experienced this issue. It might even prevent some RMAs.

I will add that to my list.


While you are adding things to your list, the wiki accessories page
for hdmi cables has an "Amazon 2" link that goes to a regular hdmi
cable, and not a micro hdmi cable.

Are you sure? Let me check again.


I see that it is supposed to work with .2013.08.20 image But the link for that image is actually 6.20. Updating_The_Software

The 8_21 image is release is still pending.


So I am now running,

root@beaglebone:~# cat /etc/dogtag

but there doesn’t seem to be a difference with the Atrix Dock.

Also: Should I be worried about the “DO-NOT-USE-FOR-PRODUCTION” note?

The new 8_21 production image was released today. You can switch to that. It is basically the same thing, just that message removed.

That image worked fine on my Atrix dock. I had to play around with some of the display options to get one that worked best, but it worked. Make sure it is all cabled up on power up so it is sure to get the EDID.


I actually downloaded and installed the img labeled as 8-21 this morning around 9:00am PST. When you say you had to play with the settings, what exactly did you set them to?

It is currently 720x576.



Ok… I think I am getting close. My uEnv.txt looks like this.

optargs=run_hardware_tests quiet

but after booting my EDID looks like this:

parse-edid: parse-edid version 2.0.0
parse-edid: EDID checksum passed.

EDID version 1 revision 3

Section “Monitor”

Block type: 2:0 3:ff

Block type: 2:0 3:fd

Block type: 2:0 3:fc

Identifier “MotoAttach”
VendorName “MOT”
ModelName “MotoAttach”

Block type: 2:0 3:ff

Block type: 2:0 3:fd

HorizSync 30-85
VertRefresh 50-75

Max dot clock (video bandwidth) 150 MHz

Block type: 2:0 3:fc

DPMS capabilities: Active off:no Suspend:no Standby:no

Mode “1366x768” # vfreq 60.000Hz, hfreq 48.000kHz
DotClock 72.000000
HTimings 1366 1380 1436 1500
VTimings 768 769 772 800
Flags “+HSync” “+VSync”

Block type: 2:0 3:ff

Block type: 2:0 3:fd

Block type: 2:0 3:fc


Shouldn’t the EDID have the same resolution as the uEnv.txt?

I use the stock uENV.txt file. That file only works for initial booting screens. After the kernel kicks in. it overrides it once the EDID is read. So no, it does not match.


OK! Now we are getting somewhere! I used the “Forcing a resolution” instructions listed Here. And set the resolution to 720x576 @50hz. Now I see a picture.

The atrix’s keyboard/mouse pad don’t work. I am guessing this is because I am using a micro usb cable->Adapter->Mini Usb port. Do I need to get a “frankencable” to get it to the Type A USB port?

Read the last sentence:

“HOWEVER, this will only set the resolution on the first stage of the boot process, when the BEAGELBONE LOGO is displayed at the beginning. After reading the EDID, the board will use the EDID as the resolution.
This will tell you if the monitor, cable, and board are all functioning”

You will need to cut the 5V wire on the USB cable to get it to work. The Dock and the board both source 5V.


I am sure this will sound like a dumb question, and I am pretty sure I know the answer. For the keyboard and touch pad to work; I need to connect the DATA leads (green&white) from the micro usb male on the the dock to a male USB A on the BBB? If I go to the mini USB on the BBB it will not work. Is that correct? Currently I have the power leads (red&black) going from the mini usb to a barrel jack and that is powering the BBB from the Atrix Dock.

That is correct. Connect to the Host USB port on the BBB. That is the one that you have to remove the 5V wire from, inside the cable. The microUSB on the board is not used in this setup.

1-HDMI cable to the board.
USB Host on the board to USB cable on the dock, 5V wire removed.


The Motorola Atrix Lapdock HDMI still doesn’t work at its native 1366x768 resolution with the Cloud9 GNOME Image 2013.09.04. I can get “close” with 1360x768, but text is a bit fuzzy in X:

Modeline "1360x768@60" 84.50 1360 1392 1712 1744 768 783 791 807 +hsync +vsync

My kernel is:
Linux beaglebone 3.8.13 #1 SMP Thu Sep 12 10:27:06 CEST 2013 armv7l GNU/Linux

See also related threads: