mpeg2dec plugin for gstreamer

Hi,

Currently, i am porting the the mpeg2dec plugin in thr gstreamer on
Android,
however, i meet a problem say "mpeg2.h" missing and finally i find it
in libmpeg2.
And i think i have to port libmpeg2 my self.

During porting the libmpeg2, i meet a problem say"make: *** No rule to
make target `build/core/motion_comp_arm_s.S', needed by `out/target/
product/beagle/obj/STATIC_LIBRARIES/libmpeg2arch_intermediates/
motion_comp_arm_s.o'. Stop.
."

I would like to ask everyone, what does it mean and how can i solve
it?

Thanks all!

Thanks and Regards,
King.S

king <king06552002@gmail.com> writes:

Hi,

Currently, i am porting the the mpeg2dec plugin in thr gstreamer on
Android,
however, i meet a problem say "mpeg2.h" missing and finally i find it
in libmpeg2.
And i think i have to port libmpeg2 my self.

Use FFmpeg. It is much faster than libmpeg2.