Narcissus, mplayer and opencv

Hi,

I wanted to see opencv demos on beagleboard so I created the X11
image using Narcissus.
For some reason it doesn't run mplayer giving error
v4l2: unable to open '/dev/video0' : No such file or directory
It runs OK on the same hardware with a console image created with the
same tool.
What is missing?

As well after
'opkg update'
I have
opkg: Invalid gzip magic

Jan

The output from Narcissus is:

Preconfiguring image
Installing packages:
   task-base-extended
   udev
   angstrom-version
   tinylogin
   initscripts
   sysvinit
   sysvinit-pidof
   kernel-modules
   alsa-utils-alsamixer
   alsa-utils-aplay
   alsa-utils-amixer
   alsa-utils-aconnect
   alsa-utils-iecset
   alsa-utils-speakertest
   alsa-utils-aseqnet
   alsa-utils-aseqdump
   alsa-utils-alsaconf
   alsa-utils-alsactl
   task-beagleboard-demo
   dropbear
   gst-plugins-bad-meta
   gst-plugins-base-meta
   gst-plugins-good-meta
   gst-plugins-ugly-meta
   i2c-tools
   mplayer
   opencv-samples
   screen
   wireless-tools
   angstrom-x11-base-depends
   angstrom-gpe-task-base
   e-wm
   e-wm-config-standard
   e-wm-config-default
   abiword
   firefox
   wireshark
Assembling image
amethyst
Click to download your janek25052009 image for beagleboard [124.63
MiB]

OK, it's not me, it's you.
Today I have tried another console image and instead I had an X11
image.
And yes, I ticked the right boxes.
It is a pity as it worked well for a while and now is falling, but
nothing is perfect.

Another question.
I have in my boot.scr the following

setenv bootcmd 'mmcinit; fatload mmc 0:1 0x80300000 uImage; bootm
0x80300000'
setenv bootargs 'console=ttyS2,115200n8 console=tty0 root=/dev/
mmcblk0p2 rw rootfstype=ext3 rw rootwait omap-dss.def_disp=lcd
omapfb.video_mode=1024x768MR-24@60'
boot

It works with kernel 2.6.28 , but with kernel 2.6.29 gives a very low
screen resolution.
Anyone can help me to fix it?
Are there any different bootargs for 2.6.29 compare to 2.6.28?

Thanks

Jan

Hey Jan,

In 2.6.29 the dss command has changed.

For Linux Kernel 2.6.29 and higher using DSS2:

omapfb.mode=dvi:1280x720MR-16@60

You might want to adjust the values to your liking

This info can be found at http://elinux.org/BeagleBoardUbuntu

I hope this helps.

Miguel

Hi Miquel,

It did help indeed.
Much appreciate it as you saved me a lot of time and frustration.
Thanks again.

Jan