Need Help Flashing BBB's emmc

I am having trouble getting my BBB to flash the emmc with a new image. I insert the mSD card, hold the User/Boot button, then apply power, wait untill all 4 lights are on and release the button. However after letting it run overnight, all four lights are not on and it has not flashed the emmc.

If I leave the card in it boots from the card no problem, and if I take it out, the old image is still there.

Any ideas?

could me one of several things:

-you are not creating the SD card correctly
-SD card could be bad
-You are powering the board over USB
-You have Ethernet plugged in when flashing
-The boot button is bad

Which instructions are you following to do the flashing?


I followed these instructions:

–If the SD card was the problem, could I still boot from it?
–The only thing pluged in is the Wall plug, no usb, or ethernet.

–Maybe a bad button I guess

Ahh. I have a better place for you to go.


Thanks that fixed it, I think I had a non eemc version installed on the drive

That could do it!


Similar problems here. I’ve been using a regular BeagleBone but am getting acquainted with the BBB now.

I’m using the CircuitCo Wiki instructions for creating an eMMC flasher uSD card. When I hold down the boot switch as I plug in the 5V barrel jack power supply, all four USER LEDs illuminate. Whether I release the boot switch right away or continue holding it, the four USER LEDs remain steadily lit. As I understand it, the USER LEDs should be flashing while the eMMC is being flashed, not constantly illuminated, correct?

I also tried to create an SD bootable disk, but I see the same thing with the LEDs. (I’m not holding the Boot Switch for the SD-bootable image since the CircuitCo Wiki does not say that you have to do so.)

Any ideas of what I could be doing wrong?

Thanks for any help!

The Wiki needs to be followed exactly. Typically what you are describing is an indication that the SD card creation process was unsuccessful. The fact that the SD card creation had the same results in both cases leads me to think there may be an issue with your 4GB SD card you are using.

You can either get another card or follow the instructions that tells you how to reformat the SD card. This process seems to work in a lot of instances.

You could also hook up the serial debug port and see what the messages are that are printed out to give an indication of what is going on.

Another possibility is that the 5V supply is a little light., It needs to be 5V.

Also make sure that the Ethernet cable is unplugged.


Aha! It was a problem with the SD card. I now remember that I was having issues with this particular card earlier. I tried reformatting as FAT and writing 0’s to the card, but still no luck with that card.

Thanks for the tips!