need help with kernel debug.

Hi,
I have a B5 BeagleBoard.
I have just built the linux kernel with these commands:

git clone git://[git.kernel.org/pub/scm/linux/kernel/git/tmlind/linux-omap-2.6.git](http://git.kernel.org/pub/scm/linux/kernel/git/tmlind/linux-omap-2.6.git) linux-omap-2.6

cd linux-omap-2.6

make CROSS_COMPILE=arm-none-linux-gnueabi- distclean
make CROSS_COMPILE=arm-none-linux-gnueabi- omap3_beagle_defconfig

make CROSS_COMPILE=arm-none-linux-gnueabi- uImage

after that I boot it and get these message:

Texas Instruments X-Loader 1.4.2 (Feb 19 2009 - 12:01:24)
Reading boot sector
Loading u-boot.bin from mmc

U-Boot 2009.06-00185-g57fe301-dirty (Jul 11 2009 - 23:20:26)

OMAP3530-GP ES2.1, CPU-OPP2 L3-165MHz
OMAP3 Beagle board + LPDDR/NAND
DRAM: 128 MB
NAND: 256 MiB
In: serial
Out: serial
Err: serial
Board revision Ax/Bx
Die ID #5bda00020000000004013ef10400e005
Hit any key to stop autoboot: 0
OMAP3 beagleboard.org # mmc init
mmc1 is available
OMAP3 beagleboard.org # fatload mmc 0 0x80300000 uImage
reading uImage

1799268 bytes read
OMAP3 beagleboard.org # bootm 0x80300000

Booting kernel from Legacy Image at 80300000 …

Image Name: Linux-2.6.31-rc1-omap1-05830-g7c
Image Type: ARM Linux Kernel Image (uncompressed)
Data Size: 1799204 Bytes = 1.7 MB
Load Address: 80008000
Entry Point: 80008000
Verifying Checksum … OK
Loading Kernel Image … OK
OK

Starting kernel …

Uncompressing Linux… done, booting the kernel.

I read in other post and every suggest turn on the debug for kernel then rebuild it but I don’t know how to do it. Could anyone please tell me how to turn on the debug in kernel?

Best regards,
Thang Nguyen.

Hi,

you should verify that u-boot passes the right bootargs to your
kernel. Type printenv in u-boot and verify that 'bootargs' specify
'console=ttyS2,115200n8'.

this is the print out of printenv command
OMAP3 beagleboard.org # printenv
bootdelay=10
baudrate=115200
loadaddr=0x82000000
console=ttyS2,115200n8
videomode=1024x768@60,vxres=1024,vyres=768
videospec=omapfb:vram:2M,vram:4M
mmcargs=setenv bootargs console=${console} video=${videospec},mode:${videomode} root=/dev/mmcblk0p2 rw rootfstype=ext3 rootwait
nandargs=setenv bootargs console=${console} video=${videospec},mode:${videomode} root=/dev/mtdblock4 rw rootfstype=jffs2
loadbootscript=fatload mmc 0 ${loadaddr} boot.scr
bootscript=echo Running bootscript from mmc …; source ${loadaddr}
loaduimage=fatload mmc 0 ${loadaddr} uImage
mmcboot=echo Booting from mmc …; run mmcargs; bootm ${loadaddr}
nandboot=echo Booting from nand …; run nandargs; nand read ${loadaddr} 280000 400000; bootm ${loadaddr}
dieid#=5bda00020000000004013ef10400e005
bootargs=console=ttyS2, [3~208 console=tty0 root=/dev/mmcblk0p2 rw rootfsype=ext3 rootwait omapfb.video_mode=1024x768MR-16@60
bootcmd=mmc init; fatload mmc 0 0x80300000 uImage; bootm 0x80300000
stdin=serial
stdout=serial
stderr=serial

Your bootargs seems to be uncorrect.

try doing the following in u-boot:

OMAP3 beagleboard.org # setenv bootargs 'console=ttyS2,115200n8
console=tty0 root=/dev/mmcblk0p2 rw rootfsype=ext3 rootwait
omapfb.video_mode=1024x768MR-16@60'
OMAP3 beagleboard.org # saveenv

and then reboot