Network interface naming

Hi all,

I recently got a second beagleboard XM to play with for some network
latentcy testing to see if these devices can be used for extremely low
latency transmission.

However i noticed that on one beagleboard the ethernet interface is
called usb0 on the other eth0, also that one device reports 256MiB
NAND which it shouldent have.

I tried to plug in another usb ethernet device to see if it was
consistent across the board but it just took the next number after the
first device.

the differences line up as below.

BB - 1
Rev B - 01
eth iface - usb0
extra usb - usb1

BB - 2
Rev B - 00 (the one i got more recently :S)
eth iface - eth0
extra usb - eth1

So where this puts me is, i would have liked to have all my ethernet
interfaces come up with the same name group. IE they all use usb* or

Can anyone suggest to me any way(s) to make all the interfaces keep
the same naming convention? tewaking udev maybe? Also if anyone can
explain why they are named different that would be great too.

Many thanks

Have you tried the same SD card in each of the two boards? NAND should not be detected for one thing as it isn’t there. I am not sure on the eth vs usb. Sounds to me like you have different versions of UBoot on each of the boards.


With both beagleboard i am using the exact same SD card as i knew i
had a working configuration. yet they come up differently.

About the NAND flash i found somewhere that some of the early XM
boards had some NAND flash but it was reccomended not to use it and i
took that advice.

Can i use udev or something to force the interfaces to use the same

Thanks for replying

I have the same output for my beagleboard-xm rev B which I bought in
Oct 2010. The ethernet ports are 'USB*' and it reports 256MB of NAND.
I didn't think the REV B have NAND but I am able to save my u-boot
environments and it stays there forever. I don't use boot.scr and my
uboot variables do not change even if I format my sd card. So I do
believe there is onboard NAND in the early rev B versions. If I do
'nand erase 260000 20000' it resets my bootdelay to 10 and mpurate to
800. When I set bootdelay to 1 and mpurate to 1000, and save with
'saveenv', the settings stay like that forever until I erase it again.
I can use any sd card with any configuration, my uboot settings will
still be the same. Therefore I believe there is NAND!!!


There were about 1000 Rev B boards in the first batch that did indeed ship with NAND. They will be marked as a 01 assembly.


Indeed mine is marked with 01. Thanks for confirming this. I am not
crazy after all.

Well, I was indeed crazy for a while. I did not recall any Rev B boards being shipped with NAND, but I was reminded that indeed about 1000 did have NAND. We had to start shipping Rev B boards before we received production units of the parts we are using today arrived.