Network Unreachable Problem

Hi everybody,

I’ve installed the systemd demo image for beagle bone and am installing packages to support opencv but am consistently running into “Network Unreachable” issues. These happen consistently with the same packages, while other, larger packages I’m able to install no problem. It makes me think that network access isn’t the issue. Any ideas?

Any help is greatly appreciated.

Thanks!

root@beagleboard:~# opkg install libopencv-imgproc-dev
Installing libopencv-imgproc-dev (2.3.1-r3) to root…
Downloading http://feeds.angstrom-distribution.org/feeds/core/ipk/eglibc/armv7a/base/libopencv-imgproc-dev_2.3.1-r3_armv7a.ipk.
libopencv-imgproc-dev: unsatisfied recommendation for jpeg-dev
libxcb-dev: unsatisfied recommendation for libxcb-shape-dev
libxcb-dev: unsatisfied recommendation for libxcb-dpms-dev
libxcb-dev: unsatisfied recommendation for libxcb-render-dev
libxcb-dev: unsatisfied recommendation for libxcb-shm-dev
libxcb-dev: unsatisfied recommendation for libxcb-damage-dev
libxcb-dev: unsatisfied recommendation for libxcb-screensaver-dev
libxcb-dev: unsatisfied recommendation for libxcb-composite-dev
libxcb-dev: unsatisfied recommendation for libxcb-res-dev
libxcb-dev: unsatisfied recommendation for libxcb-xvmc-dev
libxcb-dev: unsatisfied recommendation for libxcb-sync-dev
libxcb-dev: unsatisfied recommendation for libxcb-xevie-dev
libxcb-dev: unsatisfied recommendation for libxcb-dri2-dev
libxcb-dev: unsatisfied recommendation for libxcb-randr-dev
libxcb-dev: unsatisfied recommendation for libxcb-xprint-dev
libxcb-dev: unsatisfied recommendation for libxcb-xv-dev
libxcb-dev: unsatisfied recommendation for libxcb-record-dev
libxcb-dev: unsatisfied recommendation for libxcb-xtest-dev
libxcb-dev: unsatisfied recommendation for libxcb-glx-dev
libxcb-dev: unsatisfied recommendation for libxcb-xf86dri-dev
libxcb-dev: unsatisfied recommendation for libxcb-xfixes-dev
libxcb-dev: unsatisfied recommendation for libxcb-xinerama-dev
libx11-dev: unsatisfied recommendation for libx11-xcb-dev
libcairo-dev: unsatisfied recommendation for cairo-gobject-dev
libcairo-dev: unsatisfied recommendation for cairo-script-interpreter-dev
Multiple replacers for e2fsprogs-blkid, using first one (util-linux-blkid).
e2fsprogs-dev: unsatisfied recommendation for e2fsprogs-badblocks-dev
util-linux-dev: unsatisfied recommendation for util-linux-swaponoff-dev
util-linux-dev: unsatisfied recommendation for util-linux-umount-dev
util-linux-dev: unsatisfied recommendation for ncurses-libncursesw-dev
util-linux-dev: unsatisfied recommendation for util-linux-losetup-dev
util-linux-dev: unsatisfied recommendation for ncurses-libtinfo-dev
e2fsprogs-dev: unsatisfied recommendation for libe2p-dev
e2fsprogs-dev: unsatisfied recommendation for e2fsprogs-blkid-dev
e2fsprogs-dev: unsatisfied recommendation for libcomerr-dev
e2fsprogs-dev: unsatisfied recommendation for libss-dev
libxrender-dev: unsatisfied recommendation for xdmcp-dev
libcairo-dev: unsatisfied recommendation for cairo-perf-utils-dev
libjpeg-dev: unsatisfied recommendation for libturbojpeg-dev
gdk-pixbuf-dev: unsatisfied recommendation for jpeg-dev
libpam-dev: unsatisfied recommendation for pam-plugin-pwhistory-dev
libpam-dev: unsatisfied recommendation for pam-plugin-cracklib-dev
libpam-dev: unsatisfied recommendation for pam-plugin-debug-dev
libpam-dev: unsatisfied recommendation for pam-plugin-time-dev
libpam-dev: unsatisfied recommendation for pam-plugin-deny-dev
libpam-dev: unsatisfied recommendation for pam-plugin-access-dev
libgmp-dev: unsatisfied recommendation for libgmpxx-dev
libpam-dev: unsatisfied recommendation for pam-plugin-unix-dev
libpam-dev: unsatisfied recommendation for pam-plugin-succeed-if-dev
libpam-dev: unsatisfied recommendation for pam-plugin-warn-dev
libpam-dev: unsatisfied recommendation for pam-plugin-permit-dev
gtk±dev: unsatisfied recommendation for jpeg-dev
libtiff-dev: unsatisfied recommendation for jpeg-dev
Installing gtk±dev (2.24.8-r4) to root…
Downloading http://feeds.angstrom-distribution.org/feeds/core/ipk/eglibc/armv7a/base/gtk±dev_2.24.8-r4_armv7a.ipk.
Installing libcairo-dev (1.10.2-r6) to root…
Downloading http://feeds.angstrom-distribution.org/feeds/core/ipk/eglibc/armv7a/base/libcairo-dev_1.10.2-r6_armv7a.ipk.
Installing libx11-dev (1:1.4.4-r3) to root…
Downloading http://feeds.angstrom-distribution.org/feeds/core/ipk/eglibc/armv7a/base/libx11-dev_1.4.4-r3_armv7a.ipk.
Installing libxcb-dev (1.8.1-r0) to root…
Downloading http://feeds.angstrom-distribution.org/feeds/core/ipk/eglibc/armv7a/base/libxcb-dev_1.8.1-r0_armv7a.ipk.
wget: can’t connect to remote host (140.211.169.179): Network is unreachable
Configuring gdk-pixbuf-loader-png.
gtk-update-icon-cache: No theme index file.
Configuring gdk-pixbuf-loader-jpeg.
gtk-update-icon-cache: No theme index file.
Configuring gdk-pixbuf-loader-xpm.
gtk-update-icon-cache: No theme index file.
Configuring gdk-pixbuf-loader-gif.
gtk-update-icon-cache: No theme index file.
Collected errors:

  • opkg_download: Failed to download http://feeds.angstrom-distribution.org/feeds/core/ipk/eglibc/armv7a/base/libxcb-dev_1.8.1-r0_armv7a.ipk, wget returned 1.
  • opkg_install_pkg: Failed to download libxcb-dev. Perhaps you need to run ‘opkg update’?
  • opkg_install_cmd: Cannot install package libopencv-imgproc-dev.
  • pkg_run_script: package “gdk-pixbuf-loader-png” postinst script returned status 1.
  • opkg_configure: gdk-pixbuf-loader-png.postinst returned 1.
  • pkg_run_script: package “gdk-pixbuf-loader-jpeg” postinst script returned status 1.
  • opkg_configure: gdk-pixbuf-loader-jpeg.postinst returned 1.
  • pkg_run_script: package “gdk-pixbuf-loader-xpm” postinst script returned status 1.
  • opkg_configure: gdk-pixbuf-loader-xpm.postinst returned 1.
  • pkg_run_script: package “gdk-pixbuf-loader-gif” postinst script returned status 1.
  • opkg_configure: gdk-pixbuf-loader-gif.postinst returned 1.

I have no idea what revision board you have as you have not said. But you might check http://circuitco.com/support/index.php?title=BeagleBone to see if it may be a HW issue.

Gerald

My apologies, it’s with the beagle board (not the beagle bone as I accidentally wrote) revision C5. The problem is very consistently failing at a specific ipk file so I’m wondering if it is a bad repo entry or a timeout error. I checked the beagle board hardware page and there are no related issues from what I can tell. I’ll try the same opkg install with the non-systemd demo image and see if the problem remains.

OK! Sounds like a SW issue.

Gerald