New BBB wireless will not boot, no user LEDs, only power blinking

Hi all,

I am an experienced Pi Compute user and I recently purchased a BBB wireless to possibly migrate my project over to.

I downloaded one of the “flasher” images and flashed an SD card using Balena etcher. I inserted the SD card into the beaglebone and held that little BOOT button and applied power. I am only getting the power LED to blink about once a second. None of the user LEDs ever turn on. I thought, maybe it’s flashing the eMMC, so I left the board with the power on (power LED blinking) for a little over an hour but I am getting nothing except the same power LED blinking. I tried connecting HDMI to see if anything came up on a monitor but the screen is totally black.

Am I missing something? Should I leave it blinking for multiple hours in case it is just taking a long time to flash the eMMC?

The only thing I can think of was perhaps I damaged the board. Right when I got it I thought the OS might be preloaded so I connected a powered HDMI to VGA monitor cable and then applied power to the microUSB on the BBB. Is it possible connecting the powered HDMI cable with no OS broke the BBB?

Please try this image:

Do you have a usb serial adapter on J1? If so, please share the output.


1 Like

Thanks Robert,

Yes I downloaded that image and did the same procedure with the Beaglebone Black Wireless. Held the BOOT button down while turning on power to board. Unfortunately I got the same outcome, the power LED is still blinking.

Not sure if this means anything but instead of just blinking, sometimes when I follow the same procedure the power LED comes on steady for about 1-2 seconds and turns off. Nothing happens, the board seems to be off, when I press the POWER button on the beagleboard the board turns on and goes back to the same power LED blinking state that I am perpetually stuck in.

I do not own one of those serial adapter boards, but I am serious about this project so I purchased one from Sparkfun yesterday and it should be here be end of this coming week. I will surely let you know the output when I receive the part!

Ok just received the serial adapter in the mail. I was about to try to initiate communication with the beaglebone and I applied power to the beaglebone without pushing the boot button or plugging in this serial adapter and now the USER LEDs are lighting up…

Wow after all that trouble no serial adapter needed. I have no idea what was different, except that I did not follow the instructions to flash the board. Maybe I never tried applying power to the board without holding the boot button??

Anyway glad to be over this desolate scenario!

1 Like

With the newer images you do not need to hold down the BOOT button to flash the eMMC. You can download the Flasher image as you did and just let the board boot and go through the flash process. Then you will need to load a non-flasher image on the uSD card if you wish to boot the board from the uSD card.

The other other option is to burn a non-flasher image to a uSD card and then mount the card on a Linux system, or other system that can read the files on the imaged card. Then uncomment the flasher line at the bottom of the /boot/uEnv.txt to flash the board:

You can then boot the board with the uSD card inserted and let it go through the eMMC flasher process.
Once this is complete, you will need to power off the board and comment out the flasher line in uEnv.txt file and then boot the board again with the uSD card.