Newbie question - SERIAL not works as I want

Hello I have tried to communicate my Beagleboard C5 to my laptop via Serial port.

I had one USB to Serial adapter, I bought it in eBay, dmesg shows:
[ 9946.816413] usb 3-2: new full-speed USB device number 3 using ohci_hcd
[ 9946.983238] usb 3-2: New USB device found, idVendor=067b, idProduct=2303
[ 9946.983253] usb 3-2: New USB device strings: Mfr=1, Product=2, SerialNumber=0
[ 9946.983263] usb 3-2: Product: USB-Serial Controller
[ 9946.983270] usb 3-2: Manufacturer: Prolific Technology Inc.
[ 9946.985501] pl2303 3-2:1.0: pl2303 converter detected
[ 9947.008154] usb 3-2: pl2303 converter now attached to ttyUSB0

I also bought one serial cable, normal serial cable:
Serial RS232 DB9 Female to Female 9-Pin Cable 5ft,SR
http://www.ebay.com/itm/Serial-RS232-DB9-Female-to-Female-9-Pin-Cable-5ft-SR-/390248186240?pt=US_Parallel_Serial_PS_2_Cables_Adapters&hash=item5adc9ac180

I also bought one ribbon for Serial RS232:
Motherboard Com Port Serial Ribbon Cable bracket RS232
http://www.ebay.com/itm/Motherboard-Com-Port-Serial-Ribbon-Cable-bracket-RS232-/400307029340?pt=US_Parallel_Serial_PS_2_Cables_Adapters&hash=item5d3428855c

I have used minicom and GNU Screen but don’t works.

Did I bought somo bad component?

Thanks!!!

Di you look at the System Reference Manual trouble shooting section under Serial Port Issues? This will help you determine if your cables are good or not.

http://circuitco.com/support/files/BeagleBoard-RevC5/BeagleBoard_revC5_SRM.pdf

Gerald

if you've tried everything else, try a different USB/serial
converter. i learned early on that some USB/serial converters simply
don't work even though, when you plug them in, they use exactly the
same kernel module (pl2303) as a working converter.

rday