No bone_capemgr.9/slots file appearing

My BBB doesn’t appear to have a bone_capemgr.9/slots file:

`

root@bbb:~# cat /sys/devices/bone_capemgr.9/slots
cat: /sys/devices/bone_capemgr.*/slots: No such file or directory

`

Indeed:

`

root@bbb:~# ls -l /sys/devices/bone_capemgr.9/
total 0
-r–r--r-- 1 root root 4096 Dec 2 15:40 modalias
drwxr-xr-x 2 root root 0 Dec 2 15:40 power
lrwxrwxrwx 1 root root 0 Dec 2 15:40 subsystem → …/…/bus/platform
-rw-r–r-- 1 root root 4096 Dec 2 15:40 uevent

`

uEnv.txt - https://gist.github.com/achingbrain/0fea49ccf0e5b8db0520
dmesg - https://gist.github.com/achingbrain/e2781b1d841628ec52ea

There’s quite a lot of this stuff during boot:

`

[ 5.624964] omap_i2c 44e0b000.i2c: controller timed out
[ 6.634421] omap_i2c 44e0b000.i2c: controller timed out
[ 6.646111] bone-capemgr bone_capemgr.9: bone: scan failed (1 time)
[ 8.154145] omap_i2c 44e0b000.i2c: controller timed out
[ 9.165647] omap_i2c 44e0b000.i2c: controller timed out
[ 9.177358] bone-capemgr bone_capemgr.9: bone: scan failed (2 time)
snip
[ 26.880531] omap_i2c 44e0b000.i2c: controller timed out
[ 26.892201] bone-capemgr bone_capemgr.9: bone: scan failed (9 time)
[ 28.400049] omap_i2c 44e0b000.i2c: controller timed out
[ 29.411757] omap_i2c 44e0b000.i2c: controller timed out
[ 29.423450] bone-capemgr bone_capemgr.9: bone: scan failed (10 time)
[ 29.931273] bone-capemgr bone_capemgr.9: Failed to scan baseboard eeprom
[ 29.938347] bone-capemgr: probe of bone_capemgr.9 failed with error -110

`

Doesn’t look great.

I’m running Debian with the 3.8.13-bone28 kernel. The board is being powered by a 5v 2.5a pin barrel wall socket and has no hardware attached apart from a USB WiFi dongle and has the CPU frequency governor set to ‘performance’.

Anyone got any ideas?

Thanks in advance,

Alex

Wow bone28! That was so long ago (Sep 12, 2013 to be exact.) we just
enabled 4-bit mode on the microSD.

AM335X ES1.0 (neon ): what version of the BBB do you have?

This isn't good:

omap_i2c 44e0b000.i2c: controller timed out

With a spare microSD card, give this small standalone/microSD console
image a shot at booting:

http://elinux.org/Beagleboard:BeagleBoneBlack_Debian#BBW.2FBBB_.28All_Revs.29

Regards,

Thanks for the swift reply. I tried booting the standalone image from the link, still no slots file.

dmesg: https://gist.github.com/achingbrain/5c745fab1bdb604688c8

`

$ ls -l /sys/devices/bone_capemgr.9/
total 0
-r–r--r-- 1 root root 4096 Dec 2 16:33 modalias
drwxr-xr-x 2 root root 0 Dec 2 16:33 power
lrwxrwxrwx 1 root root 0 Jan 1 2000 subsystem → …/…/bus/platform
-rw-r–r-- 1 root root 4096 Jan 1 2000 uevent

`

Do you think the hardware could be defective?

Thanks,

Alex

Yeah... Something is wrong with the main i2c bus:

[ 1.150227] omap_i2c 44e0b000.i2c: controller timed out
[ 1.150297] tps65217 0-0024: Failed to read INT reg
[ 1.150324] tps65217 0-0024: Failed to probe pwr_but
[ 2.150218] omap_i2c 44e0b000.i2c: controller timed out
[ 3.154122] omap_i2c 44e0b000.i2c: controller timed out
[ 3.158508] tps65217: probe of 0-0024 failed with error -110
[ 3.159119] omap_i2c 44e0b000.i2c: unable to select pin group
[ 3.159768] omap_i2c 4819c000.i2c: bus 1 rev0.11 at 100 kHz
[ 3.162087] omap_i2c 4819c000.i2c: unable to select pin group

Do you have any cape's installed or any other things plugged in? (The
bus for the tps65217 isn't exposed on the headers, so it looks like a
board failure..)

If nothing is attached i'd start this process:

http://beagleboard.org/support/RMA

Regards,

Do you have any cape’s installed or any other things plugged in? (The
bus for the tps65217 isn’t exposed on the headers, so it looks like a
board failure…)

No, the only thing plugged in was the USB WiFi dongle. I just tried removing it and using ethernet instead but it didn’t make any difference.

If nothing is attached i’d start this process:

http://beagleboard.org/support/RMA

Oh well - thanks for your help.

Alex