no boot message from C4 serial port

I have been struggling some time on C4 BB issues. So far, I can not
get boot message from serial port. The serial cable has been tested OK
in loop as suggested in BB manual. I have tried Teraterm in Windows
and minicom in linux. I also tested factory default from NAND and
angstrom codes by MMC, even new patches. Nothing comes up so far. But
I found, the boot messages with BB logo go to DVI-D LCD 2 minutes
after DVI-D displays blank screen and Svideo signal is gone on TV.
There are still other issues and possible issues ahead. I just wonder
why C4 BB has not been validated before shipping? Can
anyone please suggest me how to resolve this issue?

ALL Beagle Boards are thoroughly tested before shipment. If the serial port was not working, we would not be able to program the Flash that makes the stuff show up on the display.

I suggest you look closely in section 13 of the System Reference Manual again. Make sure that the pin one of the ribbon cable aligns with pin 1 on the board. The red stripe should be next to pin 1. Also double check the serial port settings.


Hi Gerald,

I follow section 13 to double test it on factory default again.
setting is 115200 8N1, red strip is connected to pin 1. LED D5 comes
on, immediately USR0 and USR1 comes on, DVI-D is always blank and
SVideo is grey scale bar. Nothing happens on serial port terminal. I
use USB to serial adaptor on windows and linux. To confirm RS232 cable
is not faulty and cross-wired, I connect pin2 to pin3 through a wire,
type characters on serial port terminal, the characters are printed

OK. I suggest you request an RMA and get it looked at.


One more thought. You are using a twist cable from the ribbon cable to the PC, correct?


No, USB to serial adaptor is NULL Modem, so I don't need to use NULL
Modem cable

Loop back test does not guarantee cross cable functionality. If you
have a multimeter, make sure pin 2 of one end of the cable is
connected to pin 3 at the other end. Pin 5 (GND) stays on the same pin
and make sure that is present as well.

Have fun,


Dear Kai,


I use USB to serial adaptor on windows and linux. To confirm RS232 cable
is not faulty and cross-wired, I connect pin2 to pin3 through a wire,
type characters on serial port terminal, the characters are printed

can you test your cable with a different system?



Since I use USB serial NULL Modem adaptor, cross-wire is implemented
by chip in the adaptor. I measured pin5 it is connected from IDC10
pin5 to USB end. Yes, I have tested it in TeraTerm in Vista and
minicom in linux. When pin2 and pin3 are connected, I can see I type,
once disconnected, no response.

A USB to serial is NOT a null modem configuration. It has the same pinout as a PC. Beagle has the same pinout as a PC. To connect them you must have a switch between pins 2 and 3.


argh! i was casually following along in this thread, and it was
entirely unclear that you were using a USB<->serial adapter, as
opposed to an actual serial cable. that's the sort of thing you
*must* make clear from the beginning.

  i had my own adventures with USB<->serial adapters that i documented

bottom line: two allegedly functionally similar adapters: one worked,
one didn't. try a different adapter before you waste any more time.


When I bought it, it says NULL modem, otherwise there would be no
loopback when pin2 and pin 3 are connected.
I will swap pin 2 and pin 3 at DB9 end to make sure if it is cross-

Hey guys!

I could not stand to write in this thread. May be my post is pretty
much useless but I can tell that I used USB-serial adapter based on
moschip and everything began to work fine only with the rs232 cable
from the Beagle box. I use different usb-serial adapters and never
have problems with them.

      As I said in my previous response, a loop back test (physically connecting pins 2 and 3) does not confirm a cross cable. Even if you join the two pins in a straight-cable, you'll still be able to read back the characters you type. Last, but not the least, make sure the Gnd pins (pin-5 in any configuration) are connected. If the Gnd pins at both end-points are not connected, you wouldn't get the data transfer you are expecting (and no, a loopback test will not verify this).

Have fun,


Hi Guys,

Thank you for your good advice. Finally, I made it by simply swapping
pin2 and pin3 at IDC10. Indeed prolific USB serial adaptor is not NULL
modem as it claims. It has wasted me lot of time. Beagleboard should
put this in warning list!

Glad you got it working. I dont think Gerald would want to put this info. I am gathering some FAQs and would surely put this in there. :slight_smile:

Have fun,


If I were to put everything that I have run across on Beagle into the documents, I would end up with a complete electronics training course!:^). All I know id that is generally something simple.