No keyboard input in Qt Gui app without sudo

Hello there,
I am struggling with this problem for very long now, but it got really serious just now after I noticed that I also cannot use scripts. Here is the case:

I have an embedded Qt application crosscompiled that runs on BeagleBone Black. It works Ok, but one thing- It doesnt accept keyboard input if i wont run in directly on BeagleBone Black preceeding with sudo. This is a problem because:

  • I cannot remote debug application and use connected keyboard, as it doesnt work,
  • I cannot use keyboard when the app is in rc.local file to boot at startup (even though sudo is used there).

This is critical for me at the moment and I cannot find solution to the problem for very long. I would really apreciate all help regarding this.

My /etc/enviroment content is here:



Although I have tried many different configurations for QWS_KEYBOARD. The keyboard I would like to use is /dev/input/event1.

Here are my persmissions: My application rights are:

-rwxrwxrwx 1 root root 353100 Mar 2 2015 OvenViewer


And the input device rights are:

crwxrwxrwt 1 root root 13, 65 Mar 1 21:45 event1


I have set the rights in a file /etc/udev/rules.d/85-pure-data.rules:

KERNEL=="event1", MODE="777"

It really seems that all persmissions have been granted and even though, the keyboard doesnt work with Qt app
if i wont run it with sudo directly in the BeagleBone Black command line. I Also dont understand why my script in
rc.local doesnt work:

sudo /home/debian/OvenViewer -qws -nomouse &
exit 0

I have used sudo there. I would really apreciate all help with this, I am not able to proceed with my project with this problem existing and I think I have searched everywhere for the solution. I also tried with suid bit.
Please help.