No output, but ...

I bought yesterday my Beagle and I’m somehow disappointed.

Yesterday I plugged in and launched the Beagle without a problem, cause I could see the display. After testing the basics I discovered, mouse is working, but keyboard not. I thought about some USB-host-problems. I rebooted and then the problems begun. I couldn’t see any output on my screen. Therefore I did - just for sure - an upgrade to the June-version of Amstrom. But launching, no success at all.

I went today to TIGAL (local reseller of Beagle) and claimed the board. They connected everything and it worked. I checked as well the HDMI-cable and this worked as well. Back at home, not working :frowning: When I connect, I see briefly at the launch the logo of BeagleBone in the top left corner then the screen gets dark and no more cable connection found. I checked this on two monitors at home with the same result, that there is no input found.

Any hints, what to do, to get it working??? Also on my display!

Also, is this a problem of the Angstrom distro or is this independent from the distro? (I cannot really check, cause all manuals are written for Unix, which I have no real clue, how to change image via Windows. But this is another topic, and I guess, not the main issue for the very moment.)


Thx for the links. The second I used to force my settings to some reasonable resolution as as mentioned in HDMI but I wonder, why there is no default setup to eg. 720x480. After that the graphic appears and I was able to change resolution to a size which works on my monitor. Quite interesting is that the rotation doesn’t work (no display output, i.e. no HDMI recognized). Any reason for this?

But I still have two other issues, which gives me headache:

  1. Serial Connector doesn’t work
  2. Microsoft Natural Ergononmic Keyboard 4000 is not recognized (in Angstrom).

Question: In which category resp. topic should I post these?