No USB connection... and no wifi no more


I am trying to get USB connections to my three BBB rev2A boards, but they do not show up anywhere (eg dmesg or lsusb), nor do I get a network connection to (or 7.2)
Wifi works (mostly), but not really reliable enough to support a longer ssh session.

So, basically I have two questions, both about connecting to the boards.

  1. Is the USB problem a known one? getting-started instructions give the impression that should just work right out of the box.

  2. One of the boards stopped working via wifi (wifi led won’t light up, device does not show up in network scan). Is it toast now? What can I try?

What I already tried:

  • three different BBB devices (all ordered at the same date and vendor)

  • different host computers: MacMini 2012 and one Ubuntu 16.04 machine that has USB 3

  • 12V power supply connected to the board

  • fresh 2018-03 debian iot image (boot from SD Card)

  • install drivers for the mac (tried this about 2017-4, so it was only with the older image)

  • ran the linux script to register the usb device number

  • tried three different USB cables

  • looked for any visible physical damage (none found)

  • googling :wink:

  • read the troubleshooting guide… no internet explorer involved

What I did not yet try: A windows machine. In a few days I might have access to one were I may install drivers and fool around, but even if that works, it would not really solve my problem.
Also, since much on BBB is based on debian: I am mainly working on Ubuntu, maybe there is some ‘autoconnect’ service missing that is common in debian?

Thanks for any hints
Greetings, Kjell

I am having the same issue with the USB but I am using windows. I can SSH in through the wifi, but no USB access for me either.

– From my earlier post –
I flashed the 9.4 IoT 2018-06-17 build to a card and that does boot it up. Blinking lights blink away and I can connect to its WiFi. I can also SSH in via the address and the cloud9 interface works.

However, over USB nothing happens. I don’t get a new network interface when I connect it, nothing seems to install, and nothing new shows up in device manager (not in network adapters or other devices). I’ve tried two win10 computers and different cables. Flipping through some other posts on various sites, tried installing BONE_D64 driver to see if it would magically find something but no luck.


Some USB to mini/micro cables are power only; they do not have data lines. Not saying that’s your problem, but it’s happen to me.

Hello all, I am also having the same problems. Is anyone aware of a serial debug method such as using a USB to TTL Serial Cable with the Rasberry Pi but for the Beaglebone Blue? Thanks for the help

UART0, which is the default serial console connection, is pinned out on a connector on the board. You might have to make a three wire adapter cable to connect a raspberry pi serial cable to it.

— Graham

I have the same problem on both windows and Linux. I bought two Beaglebone Blues at the same tome. On the first Beaglebone, the USB works fine but on the second Beaglebone, the USB does not work. Searching the internet for a resolutitime.

Anyone on this thread find a resolution?

I booted the Beaglebone with UART0 (like Graham suggested) and found out the disk wasn't cleanly unmounted. Ran fsck and now the USB works again.

I currently have the ubuntu image from the “ROS on the EduMIP” tutorial mounted on the SD card. If I run fsck I get the following warning before running the command. I’ve read that I shouldn’t use fsck on a mounted device.


/dev/mmcblk0p1 is mounted.

WARNING!!! The filesystem is mounted. If you continue you WILL

cause SEVERE filesystem damage.

Do you really want to continue? cancelled!

check aborted.


Hi, Even I am having a similar issue. Can you please give some detail on how did you use uart0 to access it as console

Connect a serial adapter to J1, if you don't have the ftdi cable, look at:


anybody have this figured out.

oddly, I have a board that will act as an SD card normally does and come up in windows file explorer as a G: drive so it’s connecting to the windows PC. but no response via putty or surfing to the or
I’ve installed the drivers and checked with a different bbblack and a new bbblue, that part on the PC end is ok
I have not purchased the cable mentioned
I wanted to know if anyone was successful repairing or reconfiguring to make it work
the board’s access point is also, not showing up in wifi searches