no usb detection with new uImage-2.6.29-r46-beagleboard

Hello,

Today I decided to update the openembedded tree and to build the
console image, just to be up-to-date.

For some reason the beagle can't read any usb device any more (I am
using a self powered hub):

using Angstrom

root@beagleboard:~# lsusb
Bus 001 Device 001: 1d6b:0002
root@beagleboard:~#

root@beagleboard:~# uname -a
Linu Beagleboard 2.6.29-omap1 #1 PREEMPT Tue Oct 6 04:56:47 IST 2009
arm7l unknown
root@beagleboard:~#

My uboot is:
2009.06-rc2 (Jun 18 2009 - 12:55:37)

Any idea what the problem is ?, is there any issue between that kernel
and u-boot versions?
(dmesg shows nothing)

Thanks

Is that on a revC or revB?

regards,

Koen

revB7

any support issue with that?

I am having the same problem on a Rev B6 board as well.

Well, did someone succeed to have usb working with 2.6.29-r46 ?

Well, did someone succeed to have usb working with 2.6.29-r46 ?

Well, did someone succeed to have usb working with 2.6.29-r46 ?

It works on my b6 and c3 boards…

what boot version are you using? (at least on the B6)

I am using U-Boot 2009.06-rc2 and uImage-2.6.29-r47-pm2 on a revC3, and I do not have any problems with USB.

Quist

2009/10/7 Yossi <yossib@quadomedia.com>

strange, i am using the same boot version but with revB7 and it
doesn't detect any usb device.
However after installing ubuntu with 2.6.29 - 44, following
http://elinux.org/BeagleBoardUbuntu with jaunty and all usb devices
are detected (nothing changes at the boot or configuration).

This is strange.
Is there a chance it is related to the spefic usb hub i am using?,
though with previouse angstroms it worked well.

I am really prefer to fix this problem as the openembedded environment
is very convinient.

This is about the only defconfig difference between my uImage's and Angstrom's..

http://bazaar.launchpad.net/~beagleboard-kernel/%2Bjunk/2.6-stable/annotate/head%3A/patches/002-Disable_CONFIG_Gadget.diff

Basically, Angstrom's startup scripts will insmod(sp?) the otg port
which normally will detect all usb devices on the otg port just fine
(as long as you have the modules installed)..

However i'm usually using a usb based harddisk as root on my older Rev
B's... So the Angstrom boot script doesn't work for me, hence i made
that change...

Regards,

Hi:

     I have one board revB5, use openembedded 2.6.29 or use
beagleboard-kernel(branch 2.6-stable) compiled kernel, if I boot the
system with the usb otg connect, the system can't recognize the
devices.
    But if I don't connect the usb, after the kernel finished load,
connect the usb. all devices appears.

Regards

Tang YongJun

Thanks, I will give it a try.

Thanks Tang,
I gave it a try but it didn't work.
I don't even see any new message at the dmesg log.

maybe I should buy a new revC, though I have several revB7 :frowning:

Regards
Yossi

I compiled the kernel, and make some change config like beagle-
kernel,

    CONFIG_USB_CDC_COMPOSITE=y

  If config as the defconfig from openembedded for beagle board . I do
the step like:

      unconnect the usb otg.
      boot system.
      after finished the system boot. connect usb otg.
      insert one usb gadget kernel. like "insert /lib/modules/2.6.29-
omap1/kernel/drivers/usb/gadge/g_cdc.ko"

Regards

Tang YongJun

well, just to close this issue.
after returning back to that and playing around, it looks like the
problem is with the installment procedure I used.
I extracted the tarball filesystem on my host and then copied the
output to the SD card, and that's look wrong.

The right way to do so is extracting the tarball directly to the SD
card (assuming booting from SD card) using the -C /media/disk as one
of the the tar options.

Thanks.

I have been having the exact same issue, though this would appear to
activate the OTG port. Where could I place this command to insmod a
module, so it occurs every time during boot?

opkg install usb-gadget should do that for you. It even has a config file allowing you to choose which gadget should get loaded on boot.

regards,

Koen

Do you not mean usb-gadget-mode?

Thanks