nodejs complication while bitbaking cloud9-gnome-image

I’ve been trying to learn the image building process, and I managed to bitbake a systemd image successfully – so I moved on to the full cloud9-gnome-image.

I was almost successful, but had one error that killed things. The nodejs install tried to create a directory on my build machine called /usr/include/node. This operation failed due to permissions.

Why is the bitbake operation trying to do things outside of its sandbox? I would expect everything to be happening beneath ~/beaglebone/setup-scripts.


Hi Don,
I’ve been struggling with build issues, but you’ve gotten further than I have. The tips I can offer from my troubleshooting you may already know…
I’d take a look at the build’s log directory below at the config/install logs:
Also you can try to chase through some of the recipe’s…but I’ve found this to be painful (it seems like a code-browsing tool like CDT or cscope would be a useful thing…but haven’t found one yet). Here’s a link to the main recipe (bear in mind I’m new to bitbake so this is only part of the relevant recipe)

A couple of things of that might be of interest are verifying ${prefix} is indeed set correctly, and master branch moved DESTDIR in install to:

    oe_runmake install DESTDIR=${D}

All of this of course may be a red herring…if so, my apologies.

ps. What host distro are you using?


I determined the problem was a directory permission thing by looking at the log in the directory that you mentioned. The original error message (but not the summary at the end) pointed me to it.

My build attempt ended late last night, so I did not have time to do a deep dig into the recipe chain (I am dreading that), but I thought that there was no way that I was the only one that would have seen this issue ----

I’ll check the environment stuff you suggested tonight. I wish I had a dollar for every time I’ve tried to follow a blog “cookbook” procedure and found some critical detail was omitted!

My host OS is Mint 15.