not able to connect to Beaglebone black

Hi All,
I have bought beaglebone black and used tutorials to setup it. I started with start.html (provided with BBB). installed rules( Tried opening in browser but didn’t succeded. I tried finding IP of BBB using arp-scan and again got nothing. I found somewhere that by default ssh doesn’t work on angstrom so i flashed debian into an SD card and booted with that ( i refer this tute:, again i am not able to connect with BBB. In start.html there’s a link for USB to virtual Ethernet. I don’t know how would i install this (if i need to)

My system is detail is
kumar@anandlinux:~$ uname -a
Linux 3.2.0-52-generic #78-Ubuntu SMP Fri Jul 26 16:21:44 UTC 2013 x86_64 x86_64 x86_64 GNU/Linux

One of my friend suggested that i should use FTDI to USB cable to connect with BBB USB mini to USB won’t work. Is that true? Currently i’m using USB Mini to USB.

I tried using screen command too
screen /dev/ttyUSB1 115200 but that too doesn’t help.

Please suggest how can i connect. I’ve been Googling since 5th march and still clueless.

I’m using this forum for first time so if i used wrong topic/specific topic etc then let me know.

Well atleast start with something recent instead of that old image
referenced in the blog post.

Reflash with the latest from:


I installed the latest image and yet the i’m not able to connect with my BBB using any of the methods explained in my post.

Do i need to install anything for USB to virtual Ethernet. If yes then please let me know what and how.

Any link or tutorial will be appreciated.

I finally succeeded.
I installed minicom and connected using the same.
I have written a blog post for same. please refere if anyone else having this problem