Not able to enable the UART in bullseye debian OS in Beaglebone black

Hello,

I am not able to enable the UART in BeagleBone bullseye debian OS.
I followed two steps for this:

  1. Adding the dtbo file for the UART1 in /lib/firmware directory.
  2. Added this path to uEnv.txt.
    image

I followed this two steps for Buster debian OS and it worked but i am unable to make it work for Bullseye debian OS.

Can anyone help me in this?

Thanks & Regards,
Kavan Mehta

Are you sure that overlay is correct, the naming convention does not look like an official BB overlay. If its not an official overlay you will have to post the .dts file for it.

1 Like

I even tried with official BB overlay i.e. BB-UART1-00A0.dtbo but still it did not work.

What kernel are you testing with? uname -r ?

what does dmesg | grep pin show?

Regards,

Kernel is 5.10.168-ti-r72
image

dmesg | grep pin is

Well, can i assume you told it to load: BB-UART1-00A0.dtbo as above looks fine…

Here’s what i see when loading that:

debian@23-am335x-bbb:~$ cat /boot/uEnv.txt 
uname_r=5.10.168-ti-r77
cmdline=coherent_pool=1M net.ifnames=0 rng_core.default_quality=100
enable_uboot_overlays=1
enable_uboot_cape_universal=1
uboot_overlay_addr4=BB-UART1-00A0.dtbo
debian@23-am335x-bbb:~$ sudo beagle-version | grep UBOOT
UBOOT: Booted Device-Tree:[am335x-boneblack-uboot-univ.dts]
UBOOT: Loaded Overlay:[BB-ADC-00A0.kernel]
UBOOT: Loaded Overlay:[BB-BONE-eMMC1-01-00A0.kernel]
UBOOT: Loaded Overlay:[BB-HDMI-TDA998x-00A0.kernel]
UBOOT: Loaded Overlay:[BB-UART1-00A0.kernel]
debian@23-am335x-bbb:~$ dmesg | grep serial
[   10.525793] 44e09000.serial: ttyS0 at MMIO 0x44e09000 (irq = 20, base_baud = 3000000) is a 8250
[   11.416350] 48022000.serial: ttyS1 at MMIO 0x48022000 (irq = 27, base_baud = 3000000) is a 8250
[   11.427679] 48024000.serial: ttyS2 at MMIO 0x48024000 (irq = 28, base_baud = 3000000) is a 8250
[   11.438629] 481a6000.serial: ttyS3 at MMIO 0x481a6000 (irq = 43, base_baud = 3000000) is a 8250
[   11.449220] 481aa000.serial: ttyS5 at MMIO 0x481aa000 (irq = 44, base_baud = 3000000) is a 8250

I’d expect ttyS1 to be active now…

Regards,

1 Like

Yes it did work.
Thanks for the help Robert!!