not getting ip after connecting beaglebone black.

Hello,

I have beaglebone black and I have connected and update the beaglebone using
“apt-get update”

Then I have also installed kura framework.

After that I have rebooted by board. After rebooting i am not able to connect to beagle board using 192.168.7.2.
And as i check ifconfig i am getting eth5 interface but no ip address.

eth5 Link encap:Ethernet HWaddr d0:39:72:39:ad:28
inet6 addr: fe80::d239:72ff:fe39:ad28/64 Scope:Link
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:39 errors:0 dropped:0 overruns:0 frame:0
TX packets:159 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:7358 (7.3 KB) TX bytes:36433 (36.4 KB)

Also beagle board is connected please find below dmesg logs:
[ 205.505088] usb 2-1: new high-speed USB device number 7 using xhci_hcd
[ 205.521763] usb 2-1: New USB device found, idVendor=1d6b, idProduct=0104
[ 205.521773] usb 2-1: New USB device strings: Mfr=2, Product=3, SerialNumber=4
[ 205.521778] usb 2-1: Product: BeagleBoneBlack
[ 205.521782] usb 2-1: Manufacturer: Circuitco
[ 205.521786] usb 2-1: SerialNumber: 0C-0515BBBK0741
[ 205.574340] usb-storage 2-1:1.4: USB Mass Storage device detected
[ 205.574416] scsi3 : usb-storage 2-1:1.4
[ 205.574535] usbcore: registered new interface driver usb-storage
[ 205.593028] cdc_acm 2-1:1.2: This device cannot do calls on its own. It is not a modem.
[ 205.593083] cdc_acm 2-1:1.2: ttyACM0: USB ACM device
[ 205.593449] usbcore: registered new interface driver cdc_acm
[ 205.593452] cdc_acm: USB Abstract Control Model driver for USB modems and ISDN adapters
[ 205.605239] usbcore: registered new interface driver cdc_ether
[ 205.613744] rndis_host 2-1:1.0 eth0: register ‘rndis_host’ at usb-0000:00:14.0-1, RNDIS device, d0:39:72:39:ad:28
[ 205.613860] usbcore: registered new interface driver rndis_host
[ 205.638060] usbcore: registered new interface driver rndis_wlan
[ 205.653499] systemd-udevd[3556]: renamed network interface eth0 to eth5
[ 205.859738] userif-2: sent link down event.
[ 205.859744] userif-2: sent link up event.
[ 206.573980] scsi 3:0:0:0: Direct-Access Linux File-CD Gadget 0308 PQ: 0 ANSI: 2
[ 206.574652] sd 3:0:0:0: Attached scsi generic sg3 type 0
[ 206.575412] sd 3:0:0:0: [sdc] 196608 512-byte logical blocks: (100 MB/96.0 MiB)
[ 206.575605] sd 3:0:0:0: [sdc] Write Protect is off
[ 206.575611] sd 3:0:0:0: [sdc] Mode Sense: 0f 00 00 00
[ 206.575777] sd 3:0:0:0: [sdc] Write cache: enabled, read cache: enabled, doesn’t support DPO or FUA
[ 206.582277] sdc:
[ 206.583267] sd 3:0:0:0: [sdc] Attached SCSI removable disk
[ 206.945552] FAT-fs (sdc): Volume was not properly unmounted. Some data may be corrupt. Please run fsck.

Can anyone help me on this so that I can connect to my beagle board.

Thanks and Regards,
harsh