Nothing but power light comes on...??

I have an A5A board, so far I have just been using the Cloud 9 IDE so there is no SD card or anything. I have looked at some of the other forums with similar problems and the only possible solution I have seen so far is an RMA. The PWR LED turns on when the board is powered, from USB or PSU and the makes no other response. I have tried pressing the the power button and the reset button several times, nothing has happened, I have also tried holding each of them down for over 30 seconds. The reset button does nothing. Holding the power button for ten seconds causes the PWR LED to blink once, it does this every ten seconds until the button is released. During this time, the green ethernet light will occasionally blink dimly with no discernible pattern. Any suggestions as to what to do or is an RMA my only option?


This issue rarely requires an RMA. Most likely you have powered the board off by not pushing the power button and the eMMC flash is corrupted.

Try reflashing the eMMC.