ntpd time lags behind

The ntpd doesn’t work properly on my BeagleBoard. The time lags behind by about 4 seconds per minute. I assume that this is related to the latest kernel, because I did not have the problem with a previous kernel. Is anybody able to replicate the problem?

cpuinfo: ARMv7 Processor rev. 2 (v7l)
version: 3.8.13
gcc Version 4.7.3
ntpd 4.2.6p5

Setting the time with
ntpd -q -g
works perfectly.

/etc/init.d/ntpd start
starts the ntdp with the process
/usr/bin/ntpd -p /var/run/ntp.pid -g

Now the system time lags consistently behind

The following configuration files exist:


This is the most basic ntp configuration file

The driftfile must remain in a place specific to this

machine - it records the machine specific clock error

driftfile /etc/ntp.drift
logfile /var/log/ntpd.log

NTP Servers for Germany

server de.pool.ntp.org

Using local hardware clock as fallback

Disable this when using ntpd -q -g -x as ntpdate or it will sync to itself


fudge stratum 14

Defining a default security setting

restrict default

The following two files are apparently only used for automatic start at boot.


Description=Network Time Service (one-shot ntpdate mode)

ExecStart=/usr/bin/ntpd -q -g
ExecStart=/sbin/hwclock --systohc



Description=Network Time Service

ExecStart=/usr/bin/ntpd -p /var/run/ntpd.pid