OE build failure

Wait, what?

  Kernel: arch/arm/boot/Image is ready
  AS arch/arm/boot/compressed/head.o
  LZO arch/arm/boot/compressed/piggy.lzo
arch/arm/boot/compressed/head.S: Assembler messages:
arch/arm/boot/compressed/head.S:127: Error: selected processor does not support requested special purpose register -- `mrs r2,cpsr'
arch/arm/boot/compressed/head.S:134: Error: selected processor does not support requested special purpose register -- `mrs r2,cpsr'
arch/arm/boot/compressed/head.S:136: Error: selected processor does not support requested special purpose register -- `msr cpsr_c,r2'
make[2]: *** [arch/arm/boot/compressed/head.o] Error 1
make[2]: *** Waiting for unfinished jobs....
make[1]: *** [arch/arm/boot/compressed/vmlinux] Error 2
make: *** [uImage] Error 2
ERROR: oe_runmake failed

NOTE: package linux-ti33x-psp-3.2-r6a+gitr09e9651bcf2ee8d86685f2a8075bc6557b1d3b91: task do_compile: Failed
ERROR: Task 443 (/home/scratch/beagle/angstrom/setup-scripts/sources/meta-ti/recipes-kernel/linux/linux-ti33x-psp_3.2.bb, do_compile) failed with exit code '1'
Waiting for 1 active tasks to finish:
0: popt-1.16-r0 do_configure (pid 15254)
NOTE: package popt-1.16-r0: task do_configure: Succeeded
NOTE: Tasks Summary: Attempted 1020 tasks of which 1009 didn't need to be rerun and 1 failed.
fatal: '/usr/scratch/beagle/angstrom/setup-scripts/build/tmp-angstrom_2010_x-eglibc/buildhistory/images' is outside repository

Why deos the processor not support those registers? Or, why is it trying to compile with registers that aren't supported?

-ken

I ran in to this as well, the fix mentioned @ http://permalink.gmane.org/gmane.linux.linaro.devel/6500 worked for me. I don’t understand why it’s occurring at all though.

It appears to me that https://github.com/openembedded/oe-core/commit/75b8adbc042e0f65fb1286bc550d02becd3b6aea might fixe this issue.

After a rebuild on my system nothing is better though. Maybe I missed something, or maybe this isn’t the fix.

Well I just cleaned out my whole tree, started completely from scratch with a new checkout from setup-scripts (commit 37ecb7348ff252ec8ba3ee8b2418864f791e8c80), and somehow magically it got past that error. I don't understand why, but I guess that's good news.

Now I've got this new error, and I'm not sure how to track it down:

NOTE: package systemd-image-1.0-r0: task do_rootfs: Failed
ERROR: Task 8 (/home/scratch/beagle/setup-scripts/sources/meta-angstrom/recipes-images/angstrom/systemd-image.bb, do_rootfs) failed with exit code '1'
NOTE: Tasks Summary: Attempted 3282 tasks of which 2364 didn't need to be rerun and 1 failed.

Summary: 1 task failed:
  /home/scratch/beagle/setup-scripts/sources/meta-angstrom/recipes-images/angstrom/systemd-image.bb, do_rootfs

I looked in that file mentioned in the error, and didn't even see a do_rootfs task. In fact, I completely have no understanding of what that file does or why. It seems to set a bunch of bash env variables. It seems to be working with what looks to me like a random grab-bag of packages: connman, udev, systemd, and having something to do with a timestamp.

It also mentions "Task 8", but I didn't see any numbered tasks.

This was trying to build the systemd-image. Maybe I'll try building the cloud9-image instead and see if it gets any farther, or dies in the same spot.

-ken

There seems to be an issue with build history according to [1]

It worked! Thanks!

Man, I have no idea how I would have figured that out.

Thanks again!

-ken

Unfortunately, on the Beaglebone this does not help, and the build still aborts with the exact same error message, regardless if BUILDHISTORY_FEATURES="" was added to local.conf.
Is there currently no way to build a beaglebone Angstrom kernel on an Ubuntu/Linux Mint system?

Has anyone had any success in this?

-Hermann

I keep getting the same error. Any updates?

It seems you’re using an incompatible toolchain. Can you show us your kernel version and toolchain specs?

Att,

Fernando Akira Endo

Phi Innovations

Av. José Rocha Bomfim, 214 - Cj. 16
Cond. Praça Capital - Ed. Londres
Center Santa Genebra
13080-650 - Campinas - SP - Brasil
+55 19 3709-1358

2012/7/6 zero <satanasxentius@gmail.com>