OMAP3530 EVM boot from SD Card

I’m a beginner. I’m using OMAP3 EVM. Currently, I’m able to boot via NFS. But, I want it to be from SD card. I removed the boot.scr file while changing it to SD boot. It was booting properly. But, after the line 'Uncompressing Linux...' it waits for some time and then file system gets loaded directly and asks for login. The so many lines of initialization logs which used to come after the line 'Uncompressing Linux...' are completely missing. But, the root file system is fully loaded and I’m able to use it as I did previously. So, I tried making the boot.scr file by removing the nfs related arguments alone.

The boot.scr commands previously,

setenv bootargs 'mem=128M console=ttyS0,115200n8 noinitrd rw rootfstype=ext3 ip=dhcp root=/dev/nfs nfsroot=192.168.15.3:/home/mistral/nfsroot,nolock' setenv bootcmd 'mmc init; fatload mmc 0 0x80000000 uImage; bootm 0x80000000' fatload mmc 0 0x80000000 uImage bootm 0x80000000

The boot.scr commands now,

setenv bootcmd 'mmc init; fatload mmc 0 0x80000000 uImage; bootm 0x80000000' fatload mmc 0 0x80000000 uImage bootm 0x80000000

I haven’t modified the uEnv.txt. It’s contents are,

bootargs=console=ttyS0,115200n8 mem=256M root=/dev/mmcblk0p2 rw rootfstype=ext3 rootwait init=/linuxrc ip=off bootcmd=mmc rescan ; fatload mmc 0 81000000 uImage ; bootm 81000000 uenvcmd=bootd

Now, it has completely stopped booting after the line 'Uncompressing Linux...'.
Please guide me in where I’m going wrong.

Not much experience here with that board. The TI e2e community would be your best bet.

Gerald