OpenCV issues

Hello folks!

I'v been using the Beagleboard xM for about 3 months now. I'm using a
pre-built Angstrom image that boots perfectly well. I got the image
from ,
the 275MB image.

I use VNC to operate the xM through my laptop. It works pretty well,
except for the Shift key issue. :wink:

I intend to use OpenCV for image and video processing purposes on the
xM. After going through (almost) all the posts here, I tried getting
OpenCV on the board using opkg, and then doing on-board compiling.
This method started throwing up error after error, and since I was
working to a deadline (it's for a project at college), I used a
different approach.

I cross-compiled for the xM on my Ubuntu machine, and moved the binary
to the board, and ran the program, say for example edge detection.

This is the error that I get when OpenCV tries to open a window on the

OpenCV Error: Unspecified error (The function is not implemented.
Rebuild the library with Windows, GTK+ 2.x or Carbon support. If you
are on Ubuntu or Debian, install libgtk2.0-dev and pkg-config, then re-
run cmake or configure script) in cvNamedWindow, file highgui/
window.cpp, line 100
terminate called after throwing an instance of 'cv::Exception'

The binaries work perfectly - I ran a modified version of a facedetect
program such that it would work on an image stored on the SD card, and
save the output image (of a detected face with a circle around it) as
a new image next to the original image. It works, so do all such
programs, where I save the results as new images.

My real issue is with getting the windows to open so that I can do
proper video processing, while viewing results at the same time.

Thanks! :slight_smile:

Hello Parashar,
how about pasting the errors you get when trying to compile your
related programs locally on your BeagleBoard XM?
As a minimum locally you should have installed:
opencv, opencv-dev and recently koen has suggested libopencv-imgproc-
as it sets up library links properly. One person installed the latter
and it seems to
have missed configuring and another. I created all
my .so links
manually from just the basic opencv, opencv-dev install and mine
  You may have more in your program that requires other libraries for
etc. The openCV app build errors would help to diagnose. Start with a
very basic program.


Hey djlewis! Thanks for the reply!

Thing is, I don't want to indulge in on-board compiling any more.
Installing all the reqd libraries, etc. only makes the system slower.
Hence, my cross-compiling approach.

I figured out one part of what the error is. Apparently before cross
compiling, I have to configure opencv using "--with-gtk" as a
parameter. I tried this too - only to face the same problem again.
---> The 4th post from the end is what addresses my issue.

However, cross-compiling GTK+ is giving me lots of errors. Can anybody
help me with this, if they are familiar with cross compiling GTK+ for
ARM? From what I've figured out, I need to cross-compile GTK+ for ARM
- and THEN - reconfigure OpenCV with gtk.

Any help will be sincerely appreciated! :smiley: