OPKG for ubuntu running on Beaglebone bBack

Hi all,

I am using Ubuntu14.04 running on beaglebone black.
I wanted “opkg” to be installed on it. But I am not finding a correct website or repository to download it.

I tried to download the opkg from the website “http://downloads.yoctoproject.org/releases/opkg/”. But it installed opkg-cl and opkg-key not the opkg.

Can anyone please help me to download the opkg into ubuntu running on beaglebone black.

Thank you.

why? use apt-get or aptitude

Demo Image- These demonstration images contain a custom Mainline based kernel with experimental enhancements to the boards supported. They are usually updated about once a month, as new features/enhancements get added by the community. Currently, this image ships with two kernels “armv7” which is for mainline omap3+ devices (BeagleBoard/PandaBoard) and the “bone” which is specifically for the BeagleBone. The kernel is stress-tested by a farm of Panda/Beagles running 24/7 under a heavy load (building gcc trunk/mainline kernel).

git clone [https://github.com/RobertCNelson/armv7-multiplatform.git](https://github.com/RobertCNelson/armv7-multiplatform.git)
cd armv7-multiplatform
git checkout origin/v3.14.x -b tmp

git clone [https://github.com/RobertCNelson/bb-kernel.git](https://github.com/RobertCNelson/bb-kernel.git)
cd bb-kernel
git checkout origin/am33x-v3.8 -b tmp

  • Advanced Users only: Userspace, used in these demo images:

Trusty 14.04

Image Updated:

  • 2014-06-05
    • Beagle/Beagle xM: v3.14.5-armv7-x8 kernel
    • BeagleBone/BeagleBone Black: v3.8.13-bone56 kernel
    • OMAP5432 uEVM: v3.15.0-rc8-armv7-lpae-x4 kernel
  • 2014-05-06
    • Beagle/Beagle xM: v3.14.2-armv7-x5 kernel
    • BeagleBone/BeagleBone Black: v3.8.13-bone49 kernel
  • 2014-04-18
    • Beagle/Beagle xM: v3.13.10-armv7-x11 kernel
    • BeagleBone/BeagleBone Black: v3.8.13-bone47 kernel

Services Active:

Note: Depending on your internal network these may work out of the box
Apache, Port 80: [http://arm.local/](http://arm.local/) (Bone: via usb) [](
SSH, Port 22: ssh ubuntu@arm.local (Bone: via usb) ubuntu@
Getty, Serial Port

Default user: ubuntu pass: temppwd

Get prebuilt image:

wget [https://rcn-ee.net/deb/rootfs/trusty/ubuntu-14.04-console-armhf-2014-06-05.tar.xz](https://rcn-ee.net/deb/rootfs/trusty/ubuntu-14.04-console-armhf-2014-06-05.tar.xz)

Verify Image with:

md5sum ubuntu-14.04-console-armhf-2014-06-05.tar.xz
15f0237edd0f552e4fd65c0e5935ffdc  ubuntu-14.04-console-armhf-2014-06-05.tar.xz

Unpack Image:

tar xf ubuntu-14.04-console-armhf-2014-06-05.tar.xz
cd ubuntu-14.04-console-armhf-2014-06-05

If you don’t know the location of your SD card:

sudo ./setup_sdcard.sh --probe-mmc

You should see something like:

Are you sure? I don't see [/dev/idontknow], here is what I do see...

fdisk -l:
Disk /dev/sda: 500.1 GB, 500107862016 bytes **<- x86 Root Drive**
Disk /dev/sdd: 3957 MB, 3957325824 bytes **<- MMC/SD card**

sda      8:0    0 465.8G  0 disk 
├─sda1   8:1    0 446.9G  0 part /  **<- x86 Root Partition**
├─sda2   8:2    0     1K  0 part 
└─sda5   8:5    0  18.9G  0 part [SWAP]
sdd      8:48   1   3.7G  0 disk 
├─sdd1   8:49   1    64M  0 part 
└─sdd2   8:50   1   3.6G  0 part 

  • In this example, we can see via mount, /dev/sda1 is the x86 rootfs, therefore /dev/sdd is the other drive in the system, which is the MMC/SD card that was inserted and should be used by ./setup_sdcard.sh…

Install Image:

Quick install script for [board]

sudo ./setup_sdcard.sh --mmc /dev/sdX --dtb board

board options:

  • BeagleBoard Ax/Bx/Cx/Dx - omap3-beagle
  • BeagleBoard xM - omap3-beagle-xm
  • BeagleBone/Black - beaglebone
  • OMAP5432 uEVM - omap5-uevm

So for the BeagleBoard xM:

sudo ./setup_sdcard.sh --mmc /dev/sdX --dtb omap3-beagle-xm

Advanced: Build Image:

Built with a fork of project-rootstock (ARM native mode, runs directly on BeagleBoard), using a script from omap-image-builder:

git clone [https://github.com/RobertCNelson/omap-image-builder.git](https://github.com/RobertCNelson/omap-image-builder.git)
cd omap-image-builder
git checkout v2014.06 -b tmp


./RootStock-NG.sh -c rcn-ee_console_ubuntu_stable_armhf


./RootStock-NG.sh -c rcn-ee_console_ubuntu_testing_armhf


เมื่อ วันศุกร์ที่ 27 มิถุนายน ค.ศ. 2014, 11 นาฬิกา 53 นาที 08 วินาที UTC+7, Chaitra MohanKumar เขียนว่า:

What does all that have to do the OP’s question? He stated its was already installed so …

I need opkg to download qt4-embedded into beaglebone black. I tried ot apt-get and aptitude but it dint work so I was trying to download the opkg,


I already have a running ubuntu OS image on Beaglebone Black.
I need help in downloading and installing the “opkg” software on the beaglebone black.

Are you sure you are specifying the right packages?
Distros use different package names - there is no qt4-embedded in Ubuntu.

There are many packages, the main base package is qt4-default.
You can see all that are available using "apt-cache search qt4 | less".