optargs in kernel 3.15.10-bone8

BBB boot from tftp and nfs -
kernel: 3.15.10-bone8
rootfs: debian-jessie-console-armhf-2014-08-13

Hardware:
BBB A5C
Circuitco LCD4 cape
Circuitco RS232 cape

/home/rob/rootfs/boot/uEnv.txt

uname_r=3.15.10-bone8
cmdline=quiet init=/lib/systemd/systemd
optargs=“consoleblank=0”.

I used this reference http://elinux.org/Beagleboard:BeagleBone_Black_FAQ but the display is still blanking after 10 minutes.

Would appreciate some guidance.

Thanks
Rob

$ setterm -powersave off -blank 0

errr sorry, that should only be setterm -blank 0

hmm so actual that did not work for me either, which I do not know is a bug or what so here is what I had to do.

First check output of:

$ cat /sys/module/kernel/parameters/consoleblank
600

It’ll probably be 600 as above, which is ten minutes( 600 seconds ).

So . . .
nano /boot/uEnv.txt

and uncomment this line:
#cmdline=quiet init=/lib/systemd/systemd

then add at the end consoleblank=0

Which gives you
cmdline=quiet init=/lib/systemd/systemd consoleblank=0

reboot the beaglebone and when it comes back up.

@Robert

I’ll have you know that you’ve broken $optargs in the initial stage uEnv.txt.

In case you did not know already . . .

Hello,

I’m wondering if it would help if you changed from:

optargs=“consoleblank=0”

to:

optargs=consoleblank=0

I use optargs=spidev.bufsiz=16382 without a hitch on BeagleBone Debian Image 2014-09-04 running 3.14.17-ti-r17

optargs does not work in the latest uboot file setup. I’ve noticed this myself in othe situations. you have to use Robert new cmdline env variable

optargs does not work in the latest uboot file setup. I’ve noticed this myself in othe situations. you have to use Robert new cmdline env variable

https://github.com/eewiki/u-boot-patches/blob/master/v2014.07/0001-am335x_evm-uEnv.txt-bootz-n-fixes.patch

Looking at the u-boot patch it looks like optargs is used with both mmcargs and nfsargs.

Regards,
John

Ok, so rather coming in and sniping a comment Jjohn, why dont you try and set an optargs env variable in the initial uEnv.txt file and see what happens.

If you’re using the same uboot we’re using, it wont work. Now, feel free to find yourself trolling a different post.

Hi again,

I just tried wrapping my optarg in quotes and it didn’t make a lick of difference, so that’s not it.

It’s seems that I should have the latest uboot since I’m running an image from 3 days ago.
My optargs aren’t broken.

Ok, so rather coming in and sniping a comment Jjohn, why dont you try and set an optargs env variable in the initial uEnv.txt file and see what happens.

If you’re using the same uboot we’re using, it wont work. Now, feel free to find yourself trolling a different post.

Wow, that was so unnecessary. I was just trying to be helpful.

Regards,
John

try:

cat /proc/cmdline

to see if optargs show there

Since both of you seem convinced that optargs is not broken, why dont you actually go make changes to your own uEnv.txt and test if what you think will work, actually works. What I did works, as I tested it myself.

just added fauxarg to my optargs like this:

optargs=“spidev.bufsiz=16384” fauxarg

and rebooted. Now cat /proc/cmdline shows this:

console=tty0 console=ttyO0,115200n8 spidev.bufsiz=16384 fauxarg root=/dev/mmcblk0p1 rootfstype=ext4 rootwait fixrtc quiet init=/lib/systemd/systemd

Jason, odd, it seems to be working for me now too. Previously the cmdline env variable was overriding my optargs statements.

For the record. in that cmdline consoleblank=0 is declared in $optargs and init=/lib/systemd/systemd is declared in $cmdline.

Previously I had tried disabling hdmi via optargs, so maybe that is now different. Either way
optargs=capemgr.disable_partno=BB-BONELT-HDMI,BB-BONELT-HDMIN

was not working for me

I don’t know if capemanager is functional for these new fangled kernels. optargs will happily pass non functional arguments (like my fauxarg above). Maybe optargs was passing your capemgr.disable argument and it was something else that was broken?

But if you can make it work why isn’t it working for MoscowBob ??

Jason, hah ! I see why now. Can you see the problem ?

uname_r=3.15.10-bone8
cmdline=quiet init=/lib/systemd/systemd
optargs="consoleblank=0".

This is actually in the wrong file. For this to work in the file he’s using there it needs to be as i said above. Which is:

cmdline=quiet init=/lib/systemd/systemd consoleblank=0

This is because the file he’s using is the second stage uEnv.txt file and not the one loaded at boot. Which now that I think about it could have very well been my problem too.

This should be that $optargs works in the initial uEnv.txt file loaded at boot, but not the second stage uEnv.txt file which is pulled in by the stage 1 file.

False alarm ( again ).

I don't know if capemanager is functional for these new fangled kernels.
optargs will happily pass non functional arguments (like my fauxarg
above). Maybe optargs was passing your capemgr.disable argument and it was
something else that was broken?

Yes, capemgr always works with 3.8.x, however it is different. optargs does
not seem to work as it did previously.

root@arm:~# cat /sys/devices/bone_capemgr.9/slots
0: 54:PF---
1: 55:PF---
2: 56:PF---
3: 57:PF---
4: ff:P-O-L Bone-LT-eMMC-2G,00A0,Texas Instrument,BB-BONE-EMMC-2G
5: ff:P-O-- Bone-Black-HDMI,00A0,Texas Instrument,BB-BONELT-HDMI
6: ff:P-O-- Bone-Black-HDMIN,00A0,Texas Instrument,BB-BONELT-HDMIN

root@arm:~# mount /dev/mmcblk0p1 /media/boot/
root@arm:~# cat /media/boot/uEnv.txt |grep optargs=
optargs=consoleblank=0 capemgr.disable_partno=BB-BONELT-HDMI,BB-BONELT-HDMIN