OSX el Capitan breaks HoRNDIS?

According to this: http://www.joshuawise.com/horndis el Capitan breaks the HoRNDIS program.

I just started trying to connect to the BBB. Network preferences does not find the BBB.

Anyone got suggestions?

read the bug:


Looks like progress towards the end..




Anyone get this version to work? There’s certainly progress since the kext now happily loads. But nothing happens when I plug the Beaglebone in. In particular, nothing appears in System Preferences → Network, and there’s no response from Is there another step to turn “tethering” on in the Beaglebone?

If you’re just getting started and are new to using the BeagleBone Black (as I am) you’ve no doubt read and watched countless videos that insist you must get this ethernet over USB working in order to change the BBB to a static IP before you can move forward. I’ve not found this to be true. You can connect directly via ethernet. Just connect one end of an ethernet cable into your BBB, and the other directly into your Mac, or connect the BBB directly to your router (many of these tutorials say you need a crossover cable for a direct connection to your computer… it’s 2015, you do not need a crossover cable to connect directly to your computer (well, unless you’re using a relic).

I suspect you may know some of the following, I’m just going to explain it down to the basics just in case there are others who are new to the *NIX command line.

The default config of the BBB is for a DHCP connection… this will work great (all of these tutorials seem to suggest you need a static IP, you do not). The Mac’s default config on the Ethernet port will of course also be DHCP.

Open a terminal window and type:

ssh root@beaglebone.local

If it asks for a password, just hit return (there is none). You should now be connected to the BBB. If you want to find the IP so you can use Cloud9 just type:


It will respond with something like this:

eth0 Link encap:Ethernet HWaddr 6c:ec:eb:b0:0e:a0

inet addr: Bcast: Mask:

inet6 addr: fe80::6eec:ebff:feb0:ea0/64 Scope:Link


RX packets:10051 errors:0 dropped:0 overruns:0 frame:0

TX packets:866 errors:0 dropped:0 overruns:0 carrier:0

collisions:0 txqueuelen:1000

RX bytes:808671 (789.7 KiB) TX bytes:114797 (112.1 KiB)


lo Link encap:Local Loopback

inet addr: Mask:

inet6 addr: ::1/128 Scope:Host


RX packets:0 errors:0 dropped:0 overruns:0 frame:0

TX packets:0 errors:0 dropped:0 overruns:0 carrier:0

collisions:0 txqueuelen:0

RX bytes:0 (0.0 B) TX bytes:0 (0.0 B)

usb0 Link encap:Ethernet HWaddr 6c:ec:eb:b0:0e:a1

inet addr: Bcast: Mask:


RX packets:0 errors:0 dropped:0 overruns:0 frame:0

TX packets:0 errors:0 dropped:0 overruns:0 carrier:0

collisions:0 txqueuelen:1000

RX bytes:0 (0.0 B) TX bytes:0 (0.0 B)

Your IP is under eth0, in this case my board has an address of

If you want to launch Cloud9, open up a browser and enter for the URL and hit return. Cloud9 will take a few seconds to start up, and then you’re good to go.

If your want your BBB to be able to access the net from your Mac, open up your system preferences, click on sharing, and then make sure the internet sharing box is checked, and the appropriate ethernet port is selected. You can test to see if it’s working by pinging Google from the terminal (either in Cloud9, or from the terminal window you opened for SSH)

ping www.google.com

Now… if you DO want to configure a static IP, you can do that now by typing:

nano /etc/network/interfaces

There are plenty of tutorials that can show you how to modify this file… just make sure you know exactly what you want to do as modifications to this file may prevent you from connecting via ethernet the next time around.

Cheers, Joe

Answering my own question: there’s nothing more to do, except upgrade to 10.11.1. Then it all just works!

Following these steps exactly worked for me:

Hey Heath, I am running 10.11.1 on one laptop, and 10.11.2 on another laptop. I connected my BBB via USB, installed the drivers, attempted to SSH and was unable to connect. I also tried connecting via ethernet and using an external power supply, but for some reason I was not able to connect that way either.

From your message it looks like you were able to get it to work on 10.11.1? Are you able to SSH via network over USB now?

If all else fails, I have a WiFi dongle coming in the mail today that I am going to try…

I connected using Ethernet after the USB failed. It worked after a couple of tries. Haven’t tried the USB again since recent OS upgrades.

With the Ethernet, I had to use a separate USB supply, but no big deal.

Hopefully, the issue is gone now.


Yes, it definitely worked for me on 10.11.1, but I later realised it probably had more to do with the restart than the system upgrade. I think even restarting the BBB was enough to stop it working, until the next reboot of 10.11.1. If you have a power supply and an ethernet port handy, then using that ought to be a much easier and more reliable method. If I were you, I’d focus on getting that working so you’re not thwarted by funky USB tethering shenanigans.


Thanks for the tips Heath. I installed the drivers, connected both a) external power and b) the USB from the BBB to my Mac (running 10.11.1), restarted the Mac, and still can’t SSH. Weird, I guess I’ll just keep trying to troubleshoot.

Just tested with 10.11.2 and HoRNDIS rel8pre1 together with I-mobile Android 6.0.1.

Installed over the previous version. Reboot was required, but after that it worked well.

AP <-wifi-> Android Phone <-USB tethering-> OSX <-VPN-> SSH confirmed to work.

Shall I update the getting-started then? We feel confident enough to recommend this version?