Pairing a Bluetooth Headset with BeagleBoard-xm (through USB dongle)


I am trying to interface a bluetooth headset with the BeagleBoard-xM using a bluetooth USB Dongle to use the headset as a microphone. I am running Angstrom (Narcissus build).

Beagleboard recognizes the dongle :
root@beagleboard:~# lsusb
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 002 Device 002: ID 0424:9514 Standard Microsystems Corp.
Bus 002 Device 003: ID 0424:ec00 Standard Microsystems Corp.
Bus 002 Device 004: ID 1c4f:0016 SiGma Micro
Bus 002 Device 005: ID 046d:c52f Logitech, Inc.
Bus 002 Device 008: ID 0a12:0001 Cambridge Silicon Radio, Ltd Bluetooth Dongle (HCI mode)
Bus 002 Device 009: ID 090c:1000 Feiya Technology Corp. Flash Drive

root@beagleboard:~# hcitool dev
hci0 00:15:83:3D:0A:57

root@beagleboard:~# hciconfig
hci0: Type: BR/EDR Bus: USB
BD Address: 00:15:83:3D:0A:57 ACL MTU: 192:8 SCO MTU: 64:8
RX bytes:439 acl:0 sco:0 events:21 errors:0
TX bytes:72 acl:0 sco:0 commands:16 errors:0

And using hcitool I know it works to the extent that I can detect bluetooth devices in the vicinity.

root@beagleboard:~# hcitool scan
Scanning …
00:1A:7D:32:74:E6 Byte-DM5710BT

Here Byte is the headset I’m using, it is detected by hcitool scan when I put it in pairing mode and then run hcitool scan.

So far so good.

I assumed that the simplest way to pair the headset with the beagleboard would be through a GUI app, so I tried using bluetooth-applet and bluetooth-wizard, commands I entered in the terminal.

bluetooth-applet gives me a button to put bluetooth on, although there does not seem to be any response form the system after pressing that button.
bluetooth-wizard allows me to add new devices, however remains stuck at the “scanning for devices” screen, and no detected devices show up. Perhaps because bluetooth did not switch on in the first place.
Interestingly, the LED on the Bluetooth Dongle does not blink at all while bluetooth-applet is switching on bluetooth and bluetooth-wizard is scanning (as opposed to when I run hcitool scan, where the LED does blink and devices are also detected). Probably indicating that these are not accessing the dongle.

gnome-bluetooth is installed and upto date.

  1. How can I make bluetooth-applet / bluetooth-wizard use the dongle properly to switch bluetooth on and scan for devices?
  2. Is there different approach to pairing the headset with the beagleboard and using the former as a mic ?