Passwordless login to GDM for user other than root

I want to setup my BBB to have a user other than root login to the gdm without entering a password. I have editted the /etc/gdm/custom.conf file to replace root with the name of my user but the login does not complete. It either hangs at the login window waiting for a password…or it just hangs there without asking for a password. I have logged into gdm using the new user ID so I know it works.

Thanks,
Will

Make sure you have this

[daemon]
AutomaticLoginEnable=True

Don:

Thanks but no go. Below are the contents of the file /etc/gdm/custom.conf as found in the distribution Angstrom image:

[daemon]
TimedLoginEnable=true
TimedLogin=root
TimedLoginDelay=10

Obviously this is successful in having root login automatically as that is what happens! Changing root to my new user causes the login process to hang with the login form displayed but nothing further. Changing root to xuser, which also comes as part of the image, results in the same behaviour which is a hang.

There has obviously been something done when the image was built to have root login. Hopefully one of the BBB folks will see this post and help out…!

Looking at top shows that gdmconf-2 is running constantly with about 9% CPU usage.

Help!

Thanks,
Will

After a lot more research it does seem like all that should be necessary is to have these lines…

[daemon]
TimedLoginEnable=true
TimedLogin=
TimedLoginDelay=10

…in /etc/gdm/custom.conf. I have booted my BBB from a fresh flash, added my own user, changed the above to reflect the new user, and still the login greeting panel hangs. When looking at top I do not see anything obvious that is running.

PLEASE can someone HELP?

Will

Why are you not checking your logs for what is happening? I do not use Angstrom so cant really be of much use other than suggesting what upstream expects the package to “act” like. On one of my arch installs I installed GDM and setup passwordless logins as the DOCs for GDM suggest. Have you tried the non timed option? AutomaticLogin=username AutomaticLoginEnable=True Also have you this this in pam.d/gdm? then add a nopasswdlogin group and add the user to it? Not sure what version of GDM you’re on.

Don:

Thanks for your advice. First on the parameters. I did try the "auth sufficient pam_succeed_if.so user ingroup nopasswdlogin " parameter a while ago and it
did not make any difference. I think whoever did the image for the BBB used the timed login to make sure some startup stuff completed. Without it I get a message about something still running (when root is logging in).

In terms of the logs. The one place where something seems relevant is in /var/log/gdm/:0-greeter.log. It shows some permission problems that happen with my user and also with the xuser that came as part of the distribution image.

(gnome-settings-daemon:441): GVFS-RemoteVolumeMonitor-WARNING **: cannot open directory /usr/share/gvfs/remote-volume-monitors: Error opening directory ‘/usr/share/gvfs/remote-volume-monitors’: Permission denied

(polkit-gnome-authentication-agent-1:444): polkit-gnome-1-WARNING **: Unable to determine the session we are in: No session for pid 444
Xlib: extension “DPMS” missing on display “:0”.
gdm-simple-greeter[446]: GVFS-RemoteVolumeMonitor-WARNING: cannot open directory /usr/share/gvfs/remote-volume-monitors: Error opening directory ‘/usr/share/gvfs/remote-volume-monitors’: Permission denied
gdm-simple-greeter[446]: Gtk-WARNING: gtkwidget.c:5709: widget not within a GtkWindow
shell-init: error retrieving current directory: getcwd: cannot access parent directories: Permission denied
gdm-simple-greeter[446]: WARNING: Unable to load CK history: no seat-id found

I guess that I have been hoping that someone from the BBB team that created their image would see this post. There is either something wrong with the scripts behind gdm or I am just missing some key permission or group? I really, really, really don’t want to have to dig into the details of how a gdm login happens if I don’t have to.

Cheers,
Will

Sorry I cant be of more help but yes I agree your session is not being
started properly and gvfs should be putting that directory into one for
your user. Or maybe your user is not setup properly either.

I know it works in Arch Linux.

Don:

Thanks for your help… there is obviously something going on under the covers that I just don’t want to invest the time right now to try and debug. I hope that it is something simple and that someone that has it working in Angstrom world can help with. Running as root for now as that does work…!

Will