[PATCH] drivers/mmc/core/core.c: extend limit

Hi,

For some reason my 4GB Kingston SDHC class 6 cards stopped functioning
properly with 2.6.28 on my beagleboard (arm based). The very same cards (I
have two of them) worked properly with 2.6.27. What happened was that if I
booted from the card I would get errors -110.
They are similar to the ones reported at lkml last sept in
http://lkml.org/lkml/2008/9/23/390

Fortunately later on in this thread was a fix:
http://lkml.org/lkml/2008/10/20/124

This did not help me as the limit was already at 300000. However, I
decided to raise the limit to 500000. Still no go so I also doubled the
read limit from 100000 to 200000. After that the cards work without
problem. Changing the write timing back to 300000 brought the problem back
so apparently both timings need to be extended. Attached is the patch I
used for this. As it is a timeout limit value, it should not harm anyone,
and a longer timeout at least allows more cards to be used.

Signed-off-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>

This did not help me as the limit was already at 300000. However, I
decided to raise the limit to 500000. Still no go so I also doubled the
read limit from 100000 to 200000. After that the cards work without
problem. Changing the write timing back to 300000 brought the problem back
so apparently both timings need to be extended. Attached is the patch I
used for this. As it is a timeout limit value, it should not harm anyone,
and a longer timeout at least allows more cards to be used.

Unfortunately some controllers cannot cope with huge timeouts and will
complain. And such a huge timeout shouldn't be needed (and they weren't
any larger in .27).

What somewhat troubles me is that this worked in .27, so it might be this
patch does not address the root cause. Then again this is the best I can
do. If someone has a better solution, I am more than happy to test it.

Indeed. Have you enabled MMC_DEBUG and checked that the controller
actually follows the configured timeouts?

Rgds