Pin Acting Odd

Hey all,

I am pretty new to the BBB and I came across something pretty odd that I have been trying to figure out for a few hours now as I was creating a push button circuit:

P9_25 is a GPIO pin. I set it to input but noticed that it would not respond to my button. After some digging I realized that the pin itself was acting funky, so I isolated it to run some tests with BB’s Bonescript tutorial on GPIO digitalWrite(). I ran this code below (apologies for the sloppy picture) with the adjacent circuit configuration shown as well. Obviously, the LED should turn off, but it doesn’t:

I then tried the same tests on other pins, such as P9_26, and it worked perfectly, so that’s where I’m startled.

I have two theories:

  1. I messed with P9_25 in the past, and it is reconfigured in a weird way; if someone has this hunch, could you please perhaps inform me how to reset the pin to its original glory?

  2. The pin is busted. Fingers crossed for #1.

If anybody has run into something similar, or has any idea what I should do, please let me know!

Thank you for you time.


Take a look at the schematic. GPIO3_21 is connected to the output of a clock generator. To use it you must disable the Oscillator.

Oscillator can be disabled via SW
for power down modes or if
GPIO3_21 needs to be used

My suggestion is to pick another pin to work with. Less headaches.


Okay I think I see what you are saying. The MODE0 for GPIO3_21 is “mcasp0_ahclkx”, so with that beaglescript code, when I say “b.pinmode(“P9_25”,b.output)” it is outputting the results of the MODE0 (clock generator output) and not the MODE7(GPIO output) as I had expected?

But if this were the case, in my Python ADAfruit code, I explicitly set that pin to GPIO, so shouldn’t behave like that?

Thanks for your help, really trying to get a solid grasp on these concepts!


I can’t speak for the SW implementations. I just know how the board was designed.