Playing .avi, .mpg, or .mp4 files

This should be straightforward, but I’m having some problems getting this to work. Using mplayer, I use the following command: mplayer -ao alsa -vo fbdev2 -zoom -x 800 -y 480 test.mpg

Whenever I run this command, it shows the first frame, and then nothing else. I’ve tried .avi, .mpg, and .mp4 files, but they all have the same result. Has anyone been able to play videos on the BeagleBone Black?

Has anyone had any luck playing videos on the Beaglebone? It it just a setting or codec I’m missing?

I am in the process of ordering my very first BeagleBone Black so I can’t attest to how it plays videos. Maybe try a different video player such as VLC and see if it makes a difference.

Thanks for the response, but I am not using a window manager, so I can’t use VLC. I need to be able to display the video on the frame buffer. I’ve also tried ffmpeg, but no luck there either.

VLC does have a console interface via ncurses. I have used it on my desktop system before under Arch Linux and it works quite well.

I don’t know which OS you are using but I did a quick search on this forum and it seems that a VLC package is not available for Angstrom. But if you search the forums there are a bunch of posts for compiling it.

If VLC doesn’t work or you don’t want to try it then it would help if you could post the log\output from one of the video players.

Here is my output from mplayer: It just sits there and does nothing…

root@beaglebone:~# mplayer -vo fbdev2 -zoom -x 800 -y 480 rtsp://
MPlayer2 2.0-379-ge3f5043 © 2000-2011 MPlayer Team
162 audio & 361 video codecs

Playing rtsp://
Resolving for AF_INET6…

Couldn’t resolve name for AF_INET6:
Connecting to server[]: 554…

A single media stream only is supported atm.
rtsp_session: unsupported RTSP server. Server type is ‘Wowza Media Server 3.6.2.
18 build8031’.
STREAM_LIVE555, URL: rtsp://
Stream not seekable!
Detected file format:
Initiated “audio/MPEG4-GENERIC” RTP subsession on port 33062
Initiated “video/H264” RTP subsession on port 52738
VIDEO: [H264] 0x0 0bpp 24.000 fps 0.0 kbps ( 0.0 kbyte/s)
Opening video filter: [scale]
[fbdev2] Can’t put VSCREENINFO: Invalid argument
[fbdev2] Can’t put VSCREENINFO: Invalid argument
[fbdev2] Can’t put VSCREENINFO: Invalid argument
[fbdev2] Can’t put VSCREENINFO: Invalid argument
[ass] auto-open

I tried building VLC using: bitbake vlc, but it fails, and I have no idea how to fix this. The output from the bitbake recipe is below. Any suggestions?

ERROR: Function failed: do_compile (see /media/brent/Disk2/oe/setup-scripts/build/tmp-angstrom_v2012_12-eglibc/work/beaglebone-angstrom-linux-gnueabi/omap3-sgx-modules- for further information)
ERROR: Logfile of failure stored in: /media/brent/Disk2/oe/setup-scripts/build/tmp-angstrom_v2012_12-eglibc/work/beaglebone-angstrom-linux-gnueabi/omap3-sgx-modules-
Log data follows:

DEBUG: Executing shell function do_compile
NOTE: make -j2 -e MAKEFLAGS= KERNEL_PATH=/media/brent/Disk2/oe/setup-scripts/build/tmp-angstrom_v2012_12-eglibc/sysroots/beaglebone/usr/src/kernel KERNEL_SRC=/media/brent/Disk2/oe/setup-scripts/build/tmp-angstrom_v2012_12-eglibc/sysroots/beaglebone/usr/src/kernel KERNEL_VERSION=3.8.13 CC=arm-angstrom-linux-gnueabi-gcc -mno-thumb-interwork -marm LD=arm-angstrom-linux-gnueabi-ld AR=arm-angstrom-linux-gnueabi-ar BUILD=release TI_PLATFORM=ti335x
make -C /media/brent/Disk2/oe/setup-scripts/build/tmp-angstrom_v2012_12-eglibc/sysroots/beaglebone/usr/src/kernel M=pwd
make[1]: Entering directory /media/brent/Disk2/oe/setup-scripts/build/tmp-angstrom_v2012_12-eglibc/sysroots/beaglebone/usr/src/kernel' CC [M] /media/brent/Disk2/oe/setup-scripts/build/tmp-angstrom_v2012_12-eglibc/work/beaglebone-angstrom-linux-gnueabi/omap3-sgx-modules- /media/brent/Disk2/oe/setup-scripts/build/tmp-angstrom_v2012_12-eglibc/work/beaglebone-angstrom-linux-gnueabi/omap3-sgx-modules- In function 'bc_cat_init': /media/brent/Disk2/oe/setup-scripts/build/tmp-angstrom_v2012_12-eglibc/work/beaglebone-angstrom-linux-gnueabi/omap3-sgx-modules- error: implicit declaration of function 'cpu_is_omap3530' [-Werror=implicit-function-declaration] /media/brent/Disk2/oe/setup-scripts/build/tmp-angstrom_v2012_12-eglibc/work/beaglebone-angstrom-linux-gnueabi/omap3-sgx-modules- error: implicit declaration of function 'omap_rev' [-Werror=implicit-function-declaration] /media/brent/Disk2/oe/setup-scripts/build/tmp-angstrom_v2012_12-eglibc/work/beaglebone-angstrom-linux-gnueabi/omap3-sgx-modules- error: 'OMAP3430_REV_ES3_0' undeclared (first use in this function) /media/brent/Disk2/oe/setup-scripts/build/tmp-angstrom_v2012_12-eglibc/work/beaglebone-angstrom-linux-gnueabi/omap3-sgx-modules- note: each undeclared identifier is reported only once for each function it appears in cc1: some warnings being treated as errors make[3]: *** [/media/brent/Disk2/oe/setup-scripts/build/tmp-angstrom_v2012_12-eglibc/work/beaglebone-angstrom-linux-gnueabi/omap3-sgx-modules-] Error 1 make[2]: *** [/media/brent/Disk2/oe/setup-scripts/build/tmp-angstrom_v2012_12-eglibc/work/beaglebone-angstrom-linux-gnueabi/omap3-sgx-modules-] Error 2 make[1]: *** [_module_/media/brent/Disk2/oe/setup-scripts/build/tmp-angstrom_v2012_12-eglibc/work/beaglebone-angstrom-linux-gnueabi/omap3-sgx-modules-] Error 2 make[1]: Leaving directory /media/brent/Disk2/oe/setup-scripts/build/tmp-angstrom_v2012_12-eglibc/sysroots/beaglebone/usr/src/kernel’
make: *** [all] Error 2
ERROR: oe_runmake failed
ERROR: Function failed: do_compile (see /media/brent/Disk2/oe/setup-scripts/build/tmp-angstrom_v2012_12-eglibc/work/beaglebone-angstrom-linux-gnueabi/omap3-sgx-modules- for further information)
ERROR: Task 1523 (/media/brent/Disk2/oe/setup-scripts/sources/meta-ti/recipes-bsp/powervr-drivers/, do_compile) failed with exit code ‘1’
NOTE: Tasks Summary: Attempted 2477 tasks of which 2475 didn’t need to be rerun and 1 failed.
Waiting for 0 running tasks to finish:

Summary: 1 task failed:
/media/brent/Disk2/oe/setup-scripts/sources/meta-ti/recipes-bsp/powervr-drivers/, do_compile
Summary: There was 1 WARNING message shown.
Summary: There was 1 ERROR message shown, returning a non-zero exit code.

Sorry for the delay but I have been very busy of late.

I just finally ordered my BeagleBone Black today so I can’t try any of this out, however I find something to try. Apparently mplayer has a framebuffer that has been optimized for the OMAP platform → omapfb.

I don’t have time to search anymore right now but I did find a bit of documention on the following page if you scroll down the first part of the code:

The "omapfb" ip block is not on the am335x found on the BeagleBone's..


Thanks Robert, that helps a lot.

Brent, the VLC compile seems to have hit issues when it got to the OMAP code, which apparently doesn’t exist on the BBB. I am looking into the forum as other people have been trying to compile vlc and some have succeeded. I don’t know if this will solve you issue but is worth a shot.

This seemed to help someone else with a log output similar to yours from mplayer:

Also found a mention of the above potential fix on mplayers website:

2010-06-06, Sunday :: Updates and workarounds
posted by Compn

MPlayer now has the ability to use FFmpeg’s network code to access streams. Use mplayer ffmpeg://rtsp://example.invalid/ syntax to try it.

As far as the alternative live555 option, I found this informative webpage: