Pls help me with my first Debian install on the BB...

I am about to smash the BB against a wall in frustration... if you
have suggestions, they will help me to not do that...:slight_smile:

I tried to install Debian on my new BB following the instructions on
this page :
http://elinux.org/BeagleBoardDebian#Recommended_Kernel

Fine, all goes smooth, until I issue the command 'boot' on the BB. The
booting process starts, a long sequence of messages is written on the
terminal program on the laptop connected to the serial port of the BB,
then the LCD screen becomes dark, with a message saying "Input not
supported", as if the resolution of the video signal was not one of
those supported....

Following the recommendations on that page, I tried all the possible
variants, to no avail...
The LCD monitor is a 17" Acer AL1723, which should support many video
modes, and when connected as a secondary display to the laptop, it
works ok.

I have the complete log of the terminal session with all the boot
messages, if that can be of help to diagnose the reason of the
problem...

The install of the Armstrong-demo (done yesterday) went ok, and with
that the LCD monitor works without problems...

TNX
73 Alberto I2PHD

For reference, when i wrote that guide, i was using an Acer AL1916
(looking at specs it's pretty similar to your AL1723) and would get
that same message in any mode other then the one i recommend
"1280x720@60".. Strangely my dell 21inch at work has no issues in any
mode. (i'm thinking Acer's are just more pickier..)

With 2.6.28-rc's I've been having issues with usb resets. (which make
using usb adapters to download packages during the debian-install a
pain in the neck/impossible). Once that's more stabilized and viable
along with the new DSS2 framework for the video display things should
work more smoothly.

I've tested up to v2.6.28-rc6-5019ed8-oer2.. (which is currently
building in the build farm)

Please provide a boot log, I had a lot of video problems with the
original uboot-1.3.3 and a lot of those problems have gone away with
uboot-200810-rc2/etc...

Regards,

Robert Nelson wrote:

  

I am about to smash the BB against a wall in frustration... if you
have suggestions, they will help me to not do that...:slight_smile:

I tried to install Debian on my new BB following the instructions on
this page :
BeagleBoardDebian - eLinux.org

Fine, all goes smooth, until I issue the command 'boot' on the BB. The
booting process starts, a long sequence of messages is written on the
terminal program on the laptop connected to the serial port of the BB,
then the LCD screen becomes dark, with a message saying "Input not
supported", as if the resolution of the video signal was not one of
those supported....

Following the recommendations on that page, I tried all the possible
variants, to no avail...
The LCD monitor is a 17" Acer AL1723, which should support many video
modes, and when connected as a secondary display to the laptop, it
works ok.

I have the complete log of the terminal session with all the boot
messages, if that can be of help to diagnose the reason of the
problem...

The install of the Armstrong-demo (done yesterday) went ok, and with
that the LCD monitor works without problems...

TNX
73 Alberto I2PHD

For reference, when i wrote that guide, i was using an Acer AL1916
(looking at specs it's pretty similar to your AL1723) and would get
that same message in any mode other then the one i recommend
"1280x720@60".. Strangely my dell 21inch at work has no issues in any
mode. (i'm thinking Acer's are just more pickier..)

With 2.6.28-rc's I've been having issues with usb resets. (which make
using usb adapters to download packages during the debian-install a
pain in the neck/impossible). Once that's more stabilized and viable
along with the new DSS2 framework for the video display things should
work more smoothly.

I've tested up to v2.6.28-rc6-5019ed8-oer2.. (which is currently
building in the build farm)

Please provide a boot log, I had a lot of video problems with the
original uboot-1.3.3 and a lot of those problems have gone away with
uboot-200810-rc2/etc...

Regards,

I had the same issue with a newer version of uboot I believe when trying to run Angstrom. To solve it I had to set 'mode:720p60' in my bootargs environment variable. This is for a 1280x720 Dell lcd.

So I ended up typing this at uboot:

setenv bootargs 'console=ttyS2,115200n8 console=tty0 root=/dev/mmcblk0p2 rootdelay=2 rootfstype=ext3 video=omapfb:vram:2M,vram:4M,mode:720p60'

Dan

Robert,

  thanks for your answer. I sent you the terminal log and some other
info with a private message.

TNX

73 Alberto I2PHD

Hello,

Hi Robert,

thanks for your answer. I tried all the possible combination
(1280x1024@60m 1280x720@60, 1024x768@60, 720p60
and many others) but always with the same negative results.

I don't see a way to attach a file to this message, so the terminal
log is copied and pasted at the end of the message. Thanks indeed for
any help you can give me. What puzzles me is that on another SD card I
have the Armstrong demo distribution, and with that one everything is
ok. Also, when initially the color Beagleboard.org logo is displayed,
with the little dog head at the left and the penguin at the right, I
checked with the menu of the display, and it told me that the signal
had a resolution of 1280 x 720, 58 Hz of vertical freq. But putting
these value in the bootargs command did not result in anything
different....

Could you provide the output of 'uname -a' on the version of angstrom
you are running on other the SD card?

TNX

73 Alberto I2PHD i2phd@weaksignals.com
----------------------------------------------
Terminal log follows
----------------------------------------------

Texas Instruments X-Loader 1.41
Starting OS Bootloader...

U-Boot 1.3.3 (Jul 10 2008 - 16:33:09)

It's been awhile since i ran that version, i'll take a look at it
tonight and try to downgrade a unit (currently running uboot 2008-10
on all my beagles)

It's been awhile since i wrote this note in the wiki, so off the top
of my head i don't remember the reasons.
http://elinux.org/BeagleBoardDebian#Upgrading_u-boot_.282.6.27.27s_and_later.29

OMAP3530-GP rev 2, CPU-OPP2 L3-165MHz
OMAP3 Beagle Board + LPDDR/NAND
DRAM: 128 MB
NAND: 256 MiB
In: serial
Out: serial
Err: serial
Audio Tone on Speakers ... complete
Hit any key to stop autoboot: 0
OMAP3 beagleboard.org # setenv bootargs 'console=ttyS2,115200n8
console=tty0 ram
disk_size=8192 root=/dev/ram0 rw rootfstype=ext2 initrd=0x81600000,8M
video=omapfb:mode:1280x1024@60'
OMAP3 beagleboard.org # saveenv
Saving Environment to NAND...
Erasing Nand...Writing to Nand... done
OMAP3 beagleboard.org # boot
reading uImage

2198180 bytes read
reading initrd.pad

8388608 bytes read
## Booting kernel from Legacy Image at 80300000 ...
  Image Name: Linux-2.6.27
  Image Type: ARM Linux Kernel Image (uncompressed)
  Data Size: 2198116 Bytes = 2.1 MB
  Load Address: 80008000
  Entry Point: 80008000
  Verifying Checksum ... OK
  Loading Kernel Image ... OK
OK

Starting kernel ...

Uncompressing
Linux.............................................................
................................................................................
done, booting the kernel.
Linux version 2.6.27 (voodoo@voodoo-desktop) (gcc version 4.3.2
(Sourcery G++ Li
te 2008q3-41) ) #1 Fri Oct 31 12:04:40 CDT 2008
CPU: ARMv7 Processor [411fc082] revision 2 (ARMv7), cr=00c5387f
Machine: OMAP3 Beagle Board
Memory policy: ECC disabled, Data cache writeback
OMAP3430 ES2.1
SRAM: Mapped pa 0x40200000 to va 0xd7000000 size: 0x100000
CPU0: L1 I VIPT cache. Caches unified at level 2, coherent at level 3
CPU0: Level 1 cache is separate instruction and data
CPU0: I cache: 16384 bytes, associativity 4, 64 byte lines, 64 sets,
     supports RA
CPU0: D cache: 16384 bytes, associativity 4, 64 byte lines, 64 sets,
     supports RA WB WT
CPU0: Level 2 cache is unified
CPU0: unified cache: 262144 bytes, associativity 8, 64 byte lines, 512
sets,
     supports WA RA WB WT
Built 1 zonelists in Zone order, mobility grouping on. Total pages:
32512
Kernel command line: console=ttyS2,115200n8 console=tty0
ramdisk_size=8192 root=
/dev/ram0 rw rootfstype=ext2 initrd=0x81600000,8M video=omapfb:mode:
1024x768@60:
hfreq:48
Clocking rate (Crystal/DPLL/ARM core): 26.0/332/500 MHz

Regards,

Please upgrade uboot... ->
http://elinux.org/BeagleBoardDebian#Upgrading_u-boot_.282.6.27.27s_and_later.29

I tested uboot-1.3.3 (U-Boot 1.3.3 (Jul 10 2008 - 16:33:09)) from
http://beagleboard.googlecode.com/files/flash-uboot.bin

It just doesn't work with 2.6.27+ kernel's, including the ones
required to run debian/mojo. (Screen goes crazy/locksup/etc + actually
had to shutdown the LCD to get analog for my pc back)

Regards,

Alberto,

Why don’t you post the log to the mailing list so that others interested can share the problem and troubleshooting information?

I recently spent my whole Sunday on installing mojo on my BB. Although I had some hard times, Robert helped me a lot and I have my BB running X now.

You’re case would be resolved eventually and it would save somebody elses’ time in the future.

Robert,

I will post my comments out of my mojo installation experience on coming Sunday. It is part of my Sunday Development project and I don’t have much time during week days. :slight_smile: I hope it would help enhancing the wiki.

TNX
73 DE ILKYOUNG HL1OAP

2008/12/2 I2PHD <adibene@yahoo.com>

Hi, all:
When installed ubuntu under qemu, when ask software selection, which
one should be selected?
dns server, lamp server, mail server, ubutu desktop…
If I chose ubutu desktop, is that right?
Thanks
Frank
|

Hi Frank,

Just to remove any doubt of confusion, are you following the elinux
Mojo Handhelds guide?[1] If you are, only select the base package at
that software selection. When Mojo-Handhelds ported ubuntu to armv5 &
armv6, some packages required by 'ubuntu-desktop' could not be ported,
(x86 only) and therefore could not be built. However, the
ubuntu-desktop package still requires them, so aptitude will fail
during installation.

For Mojo Hasty I recommend doing a base install, followed by install
xfce4 or gnome via:

xfce4: sudo aptitude install xorg gdm xfce4
gnome: sudo aptitude install xorg gdm metacity

[1] : Ubuntu (not related to Mojo Handhelds) is on the verge of
completing a successful debian-installer build for Jaunty (9.04)
'arm', once that has built properly, i'll be creating/posting a Ubuntu
arm wiki guide on elinux. ( http://qa.ubuntuwire.com/ftbfs/ )

Regards,

Robert:
I am the installation guide from http://elinux.org/BeagleBoardHandheldsMojo.
It is found failed installation for ubuntu desktop and let me reselect so this time
I did not select anything.
One question is when do you do the command as below, in host or in beagle board? sorry I cannot try it now because the download speed is quiet low for my internet.
xfce4: sudo aptitude install xorg gdm xfce4
gnome: sudo aptitude install xorg gdm metacity
Thank you
Frank


— On Tue, 1/13/09, Robert Nelson robertcnelson@gmail.com wrote:


> From: Robert Nelson robertcnelson@gmail.com
> Subject: [beagleboard] Re: install ubuntu in qemu, which should be seleted
> To: beagleboard@googlegroups.com
> Date: Tuesday, January 13, 2009, 12:46 PM
>
> <br>> On Tue, Jan 13, 2009 at 2:24 PM, frank zhu <fzhu2000@yahoo.com> wrote:<br>> > Hi, all:<br>> > When installed ubuntu under qemu, when ask software selection, which<br>> > one should be selected?<br>> > dns server, lamp server, mail server, ubutu desktop...<br>> > If I chose ubutu desktop, is that right?<br>> > Thanks<br>> > Frank<br>> ><br>> <br>> Hi Frank,<br>> <br>> Just to remove any doubt of confusion, are you following the elinux<br>> Mojo Handhelds guide?[1] If you are, only select the base package at<br>> that software selection. When Mojo-Handhelds ported ubuntu to armv5 &<br>> armv6, some packages required by 'ubuntu-desktop' could not be ported,<br>> (x86 only) and therefore could not be built. However, the<br>> ubuntu-desktop package still requires them, so aptitude will fail<br>> during<br>> installation.<br>> <br>> For Mojo Hasty I recommend doing a base install, followed by install<br>> xfce4 or gnome via:<br>> <br>> xfce4: sudo aptitude install xorg gdm xfce4<br>> gnome: sudo aptitude install xorg gdm metacity<br>> <br>> [1] : Ubuntu (not related to Mojo Handhelds) is on the verge of<br>> completing a successful debian-installer build for Jaunty (9.04)<br>> 'arm', once that has built properly, i'll be creating/posting a<br>> Ubuntu<br>> arm wiki guide on elinux. ( http://qa.ubuntuwire.com/ftbfs/ )<br>> <br>> Regards,<br>> <br>> -- <br>> Robert Nelson<br>> http://www.rcn-ee.com/<br>> <br>>

|

Hi Frank,

You will be able to issue those commands on the Beagleboard from the
console screen. (at this point, it's like any debian based os, just on
a really small board..)

Regards,

Robert:
I have install the mojo into bb already. Feel good.
I want to re-enable serial.
According to http://elinux.org/BeagleBoardHandheldsMojo, Serial Port Console part, the script for serial port need to be edit.
There is no inittab in mojo, where should be file for ttyS2 should be located?
Could you pls be advise me how to do?
Thanks a lot
Frank

|

Hi Frank,

That serial setup was provided by another user, according to his
notes, it should be called from at bootup: /etc/securetty

Regards,

Robert:
Don’t you know where it locates? There is no locate command in mojo.
Thank you very much
Frank

— On Thu, 1/15/09, Robert Nelson robertcnelson@gmail.com wrote:


> From: Robert Nelson robertcnelson@gmail.com
> Subject: [beagleboard] Re: how to enable serial port console in mojo
> To: beagleboard@googlegroups.com
> Date: Thursday, January 15, 2009, 1:17 PM
>
> <br>> On Thu, Jan 15, 2009 at 3:04 PM, frank zhu <fzhu2000@yahoo.com> wrote:<br>> > Robert:<br>> > I have install the mojo into bb already. Feel good.<br>> > I want to re-enable serial.<br>> > According to http://elinux.org/BeagleBoardHandheldsMojo, Serial Port<br>> > Console part, the script<br>> for serial port need to be edit.<br>> > There is no inittab in mojo, where should be file for ttyS2 should be<br>> > located?<br>> > Could you pls be advise me how to do?<br>> > Thanks a lot<br>> > Frank<br>> ><br>> <br>> Hi Frank,<br>> <br>> That serial setup was provided by another user, according to his<br>> notes, it should be called from at bootup: /etc/securetty<br>> <br>> Regards,<br>> <br>> -- <br>> Robert Nelson<br>> http://www.rcn-ee.com/<br>> <br>>

|

Give this a try.

http://packages.ubuntu.com/hardy/locate

sudo apt-get install locate

Regards,