PocketBeagle ETH-WIZ-Click Not Working


I’m currently trying to get an ethernet port to work with my PocketBeagle, and can’t figure out why it won’t work.

I’ve edited the uEnv.txt file as follows:

###Overide capes with eeprom

I can also see that in /dev the spidev2.0 and spidev2.1 are listed, which to my understanding means that they are enabled.

I’ve thus tried to just plug the Eth Wiz Click into the PocketBeagle and it powers up, but it won’t connect to my computer via ethernet.

I tried using the ETH-WIZ-CLICK.dtbo but none of the SPI lines would ever show up in /dev. I’ve also configured the pins to be in SPI mode, so I’m not sure what I could be missing.

The ETH-WIZ-CLICK can be plugged onto the PocketBeagle board in two different directions.
Depending on the direction you chose, you then need to choose the correct SPI bus, “0” or “1” so that you have a working SPI bus connected to the SPI bus port on the WIZ-CLICK.
Do you have your SPI bus and the WIZ-CLICK lined up correctly?

I noted later, after using it for a while that the WIZ-CLICK uses a random number for its MAC address, and will make up a new one whenever you do a clean install of a new OS version.

I eventually got tired of the WIZ-CLICK changing its IP address and chasing it up and down the Ethernet address space.

If you put a USB-2 to Ethernet adapter on the PocketBeagle second USB port, it will run about an order of magnitude faster.
Depending on which USB adapter you use, you may still have the “random number MAC address” issue.

But it turns out that the cost of a PocketBeagle and a USB Ethernet interface is about the same price as a BBGreen, so that is what I use when I need a wired Ethernet interface.

— Graham