Powering Beaglebone through VDD_5V?

I had my Beaglebone white running a hobby ESC motor controller and when I unplugged the 5V barrel to the Beaglebone, it stayed on. The ESC was powered from a 12V source and was connected to the Beagle VDD_5V and a PWM pin, so it seems that the Beagle can stay on if it has power available through VDD_5V. I could still SSH to it.
After that, I tried booting the Beaglebone through the VDD_5V pin but it wouldn’t boot from there. In fact, I think I burnt out the micro-USB port. After trying to boot through VDD_5V, I can pass power but not data through the micro-USB. So that’s not good. Has anyone else tried powering it through VDD_5V? I guess we can keep it running through VDD_5V, but can’t boot it through there. Obviously I wouldn’t recommend trying it if you don’t know what you’re doing.

You should never connect 5V to a PWM pin. It is 3.3V only. Powering through the VDD_5V is done by the LCD 7 cape and the battery cape. Yes it has been tried. Yes it does work.


I didn’t have 5V connected to pwm. I had the Beaglebone’s VDD_5V, ground, and pwm connected to the ESC’s 5V supply, ground, and pwm, respectively. So the ESC was powering the Beagle through VDD_5V/ground. It does look like it damaged the micro-USB port though. What’s strange is that I can still boot over USB, I just can’t use it for data. That doesn’t make sense to me.

My apologies. That is the way I read your description.

The board NEVER boots over USB. It only takes power over USB. So, no data is needed.


Well yeah, but after powering it through VDD_5V, the data lines on the mini-usb line are dead. I can’t connect either way across USB. I cannot imagine how the data lines could be burnt out but the power lines still work. Maybe something was burnt out inside the hub, though I dont’ know why that would happen either. I’ll check to see if I can still transfer data over USB1.

Well, you may indeed have popped the HUB. Connecting at VDD_5V on the expansion header is the same as the power jack. Now, there are two different 5V pins. You may have picked the other one, SYS_5V by mistake. That is the one that goes to the processor USB port.