Problem booting BB

I have an SD card from beagleboardtoys.

I run this commands:

setenv bootargs 'console=ttyS2,115200n8 console=tty0 root=/dev/
mmcblk0p2 rw rootfstype=ext3 rootwait
setenv bootcmd 'mmc init; fatload mmc 0 0x80300000 uImage.bin; bootm

then tried to boot the BB. It started to boot, uncopressing uImage
etc and then get stack here:

Waiting for root device /dev/mmcblk0p2...
mmc0: new high speed SD card at address b368
mmcblk0: mmc0:b368 SD 1.90 GiB
mmcblk0: p1

Any ideas?

Thank you

The card uses the boot scripts, not a manually set environment. This card is the same as the one used in the production tests and is intended to re flash the NAND as it is when it leaves the factory. In addition, the card does not use an EXT3 file system in the testing of the board. There is not an EXT3 file system on the card. So, I doubt very much it will be able to find one.

I would try to not type in the commands for the environment, and just let the board boot. Then see what happens. Also, the card does not contain the latest UBoot and MLO that i sout there, and in most cases will not be compatible with the latest releases.


K - that begs the question - how do I "reset" the environment to

Hold the User Button down and plug in the power. As defaulted, the SD card will boot, re-flash the NAND and clear out the environment. It will then use the boot.scr file to set the environment on the boot.