Problem booting BBB using Micro SD card

After I messed up uEnv.txt on eMMC I am trying to burn image in Micro SD and boot BBB this way but no luck.

These are the steps I did:

I downloaded bone-debian-7.5-2014-05-14-2gb.img.xz.
Extracted to bone-debian-7.5-2014-05-14-2gb.img
From Ubuntu Host machine executed: sudo dd if=bone-debian-7.5-2014-05-14-2gb.img of=/dev/sdc bs=1M
After some time about 681 MB size image is written to Micro SD card. Now I am assuming this image has everything you need. kernel, filesystem and bootloader and I DO NOT have to manually make partitions (for kernel, fs and swap) on the SD card. Please verify.
Then I plug in the Micro SD card to the BBB and attached my USB cord from Host to target while pressing on S2 boot button. I also tried using 5V power supply.
All 4 LEDS flashed after a minute only fourth LED flashes interval of a second. LED next to 5V power supply is solid lit.
May be BBB booted with Linux but I have no way of knowing. I can not see it through my COM port (before when booted with eMMC I could see the COM port and connect to BBB with terra term).
I really wished BBB had serial port like most boards have.
Another question is I do not want Linux kernel loaded from either eMMC or MicroSD card I want to setup NFS and tftpboot for that I want to prompt on uboot. How can I do that?

It does have a serial port.
Software name ttyO0, Hardware name: Serial Debug Header.
See SRM (System Reference Manual) page 90.
Purchase an FTDI TTL-232R-3V3 to talk to it.

I can’t imagine working on or programming a BBB without one.

If you live in the US, or can easily order from the US, get one from
Mouser part number: 895-TTL-232R-3V3 $20.

— Graham

If in the UK then you can get one from amazon

I had the same issue of not reprogramming the mmc...
The solution that worked for me was to format the sd card and put latest version of debian....

Hope this helps...

If you are from India where to find this FTDI adapter?