problem compiling libgd

I am trying to compile libgd from source because I could not find a premade package.

I downloaded libgd 2.1.0 from the libgd.org source site.

I ran configure with no options.

Running make, I get a strange error at the end of the build process.
It looked like a problem with libfreetype, but I have that package.

The error message says:

/bin/sed: can’t read =/usr/lib/libfreetype.la: No such file or directory

The /usr/lib/freetype.la file does exist and is readable. It looks OK in an editor.

I added some ‘echo’ statements to the libtool script. I think it is
trying to find the file ‘=/usr/lib/freetype.la’ with the equals sign in there.

I have no idea how this works or where that might be coming from.
Any hints?

I have located it to a particular part of the libtool script.

It looks like the libgd people create their own libtool script. :frowning:
I have registered a bug on the libgd.org website.

If I replace their libtool with /usr/bin/libtool I get a different error:
/usr/lib/gcc/arm-angstrom-linux-gnueabi/4.7.3/…/…/…/…/arm-angstrom-linux-gnueabi/bin/ld: cannot find -lgcc_s

Any hints on what libgcc_s is?

Problem with compiling libgd-2.1.0 on Beaglebone Black has been solved.

The libgd developers pointed out an error in file

/usr/lib/libfontconfig.la

Remove “-L/usr/lib” from the dependency libs line and it compiles ok.

Chris