Problem NEON register values in Linux Application

Hello,

I am using NEON registers in my Linux based application running on
Angstrom Demo kernel(version 2.6.29-omap1kernel) and RFS.

I am debugging application through gdbserver.

I have used ARM inline assembly in my application which is also uses
FFT functions.

ARM inline assembly routine uses NEON registers q0 to q12 and also ARM
r0-r12 registers.

When I run my ARM inline assembly routine in independent application
then it working fine, I am getting output as per expected.

When I am using this ARM inline assembly routine in application then
it's not giving output as per expected.

I have checked through GDBserver so I came to know that in "info all-
register" command doesn't showing NEON registers. like below
1584-interpreter-exec console "info all-registers"
~"r0 0x3cec8c"
r0 0x3cec8c~"\t3992716"
3992716~"\n"
~"r1 0x305"
r1 0x305~"\t773"
773~"\n"
.............................
..............
........
~"r12 0xffff"
r12 0xffff~"\t65535"
65535~"\n"
.............
.........
.....

"f0 0"
f0 0~"\t(raw 0x00025ea40000000000000000)\n"
(raw 0x00025ea40000000000000000)
~"f1 0"
f1 0~"\t(raw 0x00025ea40000000000000000)\n"
(raw 0x00025ea40000000000000000)
~"f2 0"
f2 0~"\t(raw 0x00025ea40000000000000000)\n"
(raw 0x00025ea40000000000000000)
................
.........
....
~"f7 0"
f7 0~"\t(raw 0x00025ea40000000000000000)\n"
(raw 0x00025ea40000000000000000)
~"fps 0x0"
fps 0x0~"\t0"
0~"\n"

~"cpsr 0x20000010"
cpsr 0x20000010~"\t536870928"
536870928~"\n"

So here I am not getting q0-q15 register details.
I have also tried to check NEON reg values at run time on debugging
through "print $d0" command on gdb running on host, but getting
~"$14 = void"
$14 = void~"\n"

So here what should be problem ? Does it have any configuration need
to add to make NEON registers works?
I have given compilation option " -O3 -g3 -Wall -c -fmessage-length=0 -
march=armv7-a -mtune=cortex-a8 -mfpu=neon -mfloat-abi=softfp -v -
fcommon -mcpu=cortex-a8"
I am using codesourcery tool chain.
please guide me how to proceed further.

Thanks,
Rachit

When working with assembly I advice you to say which version of
compiler your using.
Apparently, that ability to view vfp/neon register with code
sourcery's gdb is available in the last version 2009
http://www.codesourcery.com/sgpp/news/spring_2009.html

Are you using this version of tools ?

Hello,
I am using code sourcery's Personal edition version Sourcery G++
4.3-205

thanks,