Problem NFS Booting BeagleBone - Kernel Hangs


just to be on safe side: did you try to boot with the same kernel you’re downloading on the beaglebone via nfs from the sd card? this test allows you to be sure that kernel itself works well for your bone. I used to have your same issues (kernel freeze during boot and stuck on “Uncompressing Linux… done, booting the kernel” message). The root cause of this problem was not NFS itself.

When you are safe your kernel works well, we will try something else to fix this issue.



Hello Daniele,

Yes, and I should have mentioned that in my original post. Everything works when I boot from the SD card (same kernel image, same initrd.img, same uBoot, same x-loader, same Ubuntu rootfs). There are some errors; however, they do not prevent the kernel from booting and displaying the login prompt. FWIW: Following is the boot log from the successful boot from the SD card.

OK, this is embarrassing… I just found the first major problem. After looking around some more, I noticed that a lot of people were not setting console correctly. So I double checked my setting. It is really hard to tell, but I was setting my console to tee-tee-y-double-zero, instead of tee-tee-y-Oh-zero. This gets me to the point where I can see the kernel booting; however, I am still not in the clear. The end of my bootlog looks like this:

2012-11-20T09:13:09.625 - [ 2.365325] Freeing init memory: 248K
2012-11-20T09:13:09.689 - Loading, please wait…
2012-11-20T09:13:09.721 - [ 2.453735] mmc0: host does not support reading read-only switch. assuming write-enable.
2012-11-20T09:13:09.737 - [ 2.479614] mmc0: new high speed SDHC card at address 1234
2012-11-20T09:13:09.753 - [ 2.491241] mmcblk0: mmc0:1234 SA04G 3.63 GiB
2012-11-20T09:13:09.753 - [ 2.500244] mmcblk0: p1 p2
2012-11-20T09:13:09.817 - [ 2.563385] udevd[67]: starting version 175
2012-11-20T09:13:09.881 - Begin: Loading essential drivers … FATAL: Could not load /lib/modules/3.2.33-psp26/modules.dep: No such file or directory
2012-11-20T09:13:09.913 - FATAL: Could not load /lib/modules/3.2.33-psp26/modules.dep: No such file or directory
2012-11-20T09:13:09.929 - FATAL: Could not load /lib/modules/3.2.33-psp26/modules.dep: No such file or directory
2012-11-20T09:13:09.977 - FATAL: Could not load /lib/modules/3.2.33-psp26/modules.dep: No such file or directory
2012-11-20T09:13:09.977 - done.
2012-11-20T09:13:09.993 - Begin: Running /scripts/init-premount … done.
2012-11-20T09:13:10.041 - Begin: Mounting root file system … Begin: Running /scripts/local-top … done.
2012-11-20T09:13:40.070 - Gave up waiting for root device. Common problems:
2012-11-20T09:13:40.070 - - Boot args (cat /proc/cmdline)
2012-11-20T09:13:40.071 - - Check rootdelay= (did the system wait long enough?)
2012-11-20T09:13:40.071 - - Check root= (did the system wait for the right device?)
2012-11-20T09:13:40.086 - - Missing modules (cat /proc/modules; ls /dev)
2012-11-20T09:13:40.086 - ALERT! /dev/nfs does not exist. Dropping to a shell!
2012-11-20T09:13:40.102 - FATAL: Could not load /lib/modules/3.2.33-psp26/modules.dep: No such file or directory
2012-11-20T09:13:40.102 - FATAL: Could not load /lib/modules/3.2.33-psp26/modules.dep: No such file or directory
2012-11-20T09:13:40.416 -
2012-11-20T09:13:40.417 -
2012-11-20T09:13:40.435 - «Bª%Õ¹ÑÕÒrÂΩS)S¬WS%$¬]Últ-in shell (ash)
2012-11-20T09:13:40.435 - Enter ‘help’ for a list of built-in commands.
2012-11-20T09:13:40.435 -
2012-11-20T09:13:51.504 - (initramfs)
2012-11-20T09:13:52.080 - (initramfs)
2012-11-20T09:13:52.352 - (initramfs)

What is that all about?? It looks like it is failing to mount my Ubuntu rootfs over NFS (due to the log: ALERT! /dev/nfs does not exist. Dropping to a shell!). Why would this be, it was just able to transfer the files over just fine.


A lot has happened since my last post. I found a number problems with my configuration, and I am much closer. However, still no login prompt. It looks like I might be having a similar problem to what Daniele has already solved. This is what the tail of the bootlog now looks like: