Problem with BeagleBoard Rev B5

BeagleBoard Rev B5 problem

Hello everyone, I bought, in September 2008, two BeagleBoard.
I remember that i had tried them and I have installed a few distros.

Some days ago I retry to use them.
Both starts and show the splashscreen with the dog.

One of them does nothing more than showing the splashscreen

The other one, with a SD inserted, show the black screen with the
penguin in the upper left and a lot of writings beginning with:
"Kernel panic - not syncing: CFS: Unable to mount root fs on unknow-
block (179.5) ... "

I tried using archlinux, ubuntu and angstroms.
For all i made the partition for the bootloader as fat16 and fat32.
Ext2 and ext3 for rootfs. Always the same result.

Without SD nothing happens (except the splashscreen with the dog).

The USB serial does not exist or I don't see it from XP or Linux.

I do not receive anything from the RS232 connector (I
tried several cables, and I made a brandnew one).

So, my questions are:

1) Probably what is shown when the BB starts ("kernel panic..") is the
result of nand boot, not the SD boot.
Why I don't reach to boot from SD? If I press the user botton the
board show me an orange/yellow screen.

2) I found MLO, u-boot.bin and uImage files for version C.
Could these file be a problem for my version B5 boards ?
If yes, where I could find these files for version B5?

3) Why the serial doesn't work?

4) Are both hopelessly bricked?

thank you