Problem with enable SPI dev control in BeagleboneBlack.

Hi,

I am trying to enable SPI control in BBB refer: http://elinux.org/BeagleBone_Black_Enable_SPIDEV

Here is my DTS:

&am33xx_pinmux {
spi1_pins: pinmux_spi1_pins {` pinctrl-single,pins = < ```0x108 (PIN_OUTPUT_PULLUP | MUX_MODE2) ``/* MII1_COL.spi1_sclk */``` ```0x10C (PIN_INPUT_PULLUP | MUX_MODE2) ``/* MII1_CRS.spi1_d0 */``` ```0x110 (PIN_INPUT_PULLUP | MUX_MODE2) ``/* MII1_RX_ER.spi1_d1 */``` ```0x144 (PIN_OUTPUT_PULLUP | MUX_MODE2) ``/* RMII1_REF_CLK.spi1_cs0 */``` ```0x164 (PIN_OUTPUT_PULLUP | MUX_MODE2) ``/* ECAP0_IN_PWM0_OUT.spi1_cs1 */``` ```>;
};` `};` `` `&spi1 {` status = "okay"; ```pinctrl-names = ``"default"``;
pinctrl-0 = <&spi1_pins>;` `` spi1_0 { ```#address-cells = <1>;``` ```#size-cells = <0>;``` ```reg = <0>;
spi-max-frequency = <24000000>;` compatible = "spidev"; ```};
```spi1_1 {` ```#address-cells = <1>;``` ```#size-cells = <0>;``` ```reg = <1>;` ```spi-max-frequency = <24000000>;` ```compatible =“spidev”``; ```};
};

CONFIG_SPI_DEV was enabled.

But I can’t find any /dev/spi*. What did I do wrong? I am using kernel 3.14

Thanks

Tuan Nguyen

look at the log ! dmesg | grep spi

do you see something ?