problem with gst ti plugin and phonon

hi. all

  I want to know if gst ti plugin can work properly with phonon, or
has it been tested with phonon?

  I want to tell you what I had done with this plugin and phonon. At
first, I got gst ti pluign work well on beagleboard, I can play
video/audio using this plugin. I use DMAI_DEBUG=2 to trace the log,
and I can see some debug messages from DMAI. And I also note that the
cpu is loaded only about 10%. Of course, this had been done using
gst-launch, and create a proper pipeline using commnad. I tested as
gst-launch filesrc location=/media/ram/4.mp4 ! typefind ! qtdemux
name=demux demux.audio_00 ! queue max-size-buffers=1800
max-size-time=0 max-size-bytes=0 ! typefind ! TIAuddec1 ! alsasink
demux.video_00 ! typefind ! TIViddec2 ! TIDmaiVideoSink
videoStd=D1_NTSC displayDevice=/dev/fb2 displayStd=fbdev
resizer=FALSE accelFrameCopy=TRUE

  Since previous has worked, so I want to know what about phonon to
use this plugin, in order to get dsp acceleration. I use pnonon to
play a video, the TI watermark is at the top right corner of the
video, and the trace log shows something from DMAI, like this
"@0x006252af:[T:0x4668d490] ti.sdo.dmai - [Vdec2] VIDDEC2_process()
ret 0 inId 2 inUse 0 consumed 40".
   To my surprise, when I watch the cpu load, the cpu has been loaded
about 97% and even above that. it seems like I don't get the dsp
accelerator worked. I attached the log what I captured from console,
want to give you more detail about this trace.

  is there any problem? what's wrong with phonon and this plugin? any
suggestion is highly appreciated :slight_smile:

  can gst ti plugin work with pnonon? does phonon source code needed
to be modified according to gst ti plugin interfaces?