Problem with ncurses-native 5.4-r19 while runing bitbake for the first time...

Hi,
      I'm new with the beagle, and I'm facing a problem while trying
"bitbake nano" for the first time after its installation. I've
followed all steps recommended and didn't installed bitbake, just
uncompress the .tgz in /stuff/bitbake.
      My environment variables are: PATH=/stuff/bitbake/bin:/usr/local/
sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/games and
BBPATH=/stuff/build:/stuff/openembedded.
      I'm runing Ubuntu linux 4.3.3-5ubuntu4 , Linux version 2.6.28-15-
generic.
     This is an extract of the error reported:

checking for src modules... ncurses progs tack panel menu form

configure: creating ./config.status
./config.status: line 512: ]([ABCDGIRSTW][ABCDGIRSTW]*)[: command

not found

./config.status: line 513: syntax error near unexpected token `('
./config.status: line 513: `lt_cv_sys_global_symbol_to_cdecl='sed -n

-e 's/^T .* \(.*\)$/extern int \1();/p' -e 's/^[ABCDGIRSTW]* .* \(.*\)
$/extern char \1;/p'''

FATAL: oe_runconf failed

NOTE: Task failed: /stuff/build/tmp/work/i686-linux/ncurses-native-5.4-
r19/temp/log.do_configure.4701
ERROR: TaskFailed event exception, aborting
ERROR: Build of /stuff/openembedded/recipes/ncurses/ncurses-
native_5.4.bb do_configure failed
ERROR: Task 386 (/stuff/openembedded/recipes/ncurses/ncurses-
native_5.4.bb, do_configure) failed
NOTE: Tasks Summary: Attempted 278 tasks of which 278 didn't need to
be rerun and 1 failed.
ERROR: '/stuff/openembedded/recipes/ncurses/ncurses-native_5.4.bb'
failed

      Could it be a missing package or an issue with my environment
variables?
      I've seen the file "config.status" and at line 512 there is a
"sed" command, this is the extract of this file:

512> lt_cv_sys_global_symbol_pipe='sed -n -e 's/^.*[ ]\([ABCDGIRSTW]
[ABCDGIRSTW]*\)[ ][ ]*\([_A-Za-z][_A-Za-z0-9]*\)$/\1 \2
\2/p''
513> lt_cv_sys_global_symbol_to_cdecl='sed -n -e 's/^T .* \(.*\)$/
extern int \1();/p' -e 's/^[ABCDGIRSTW]* .* \(.*\)$/extern char \1;/
p''ere is call to sed command, which is installed and

     I will appreciate your help with this issue because I'm stuck.

Thanks,
Alex.

Hi Alex,
     I'm another newbie. I've faced similar problems in building base-
image, console-image and x11-image. All three got stuck at the package
qemu-native. Finally, I tried to bitbake this package separately with `
$bitbake qemu-native´. It was built alright. After that, base-image
got stuck at the package blueprobe. I tried to build it individually,
it was done again, then I went on building base-image. Following base-
image, the other two packages, console-image and x11-image, also have
been built with no error. So, I suggest you to bitbake ncurses-native
separately. Maybe this workaround works also in your case.

Regards

Caner

Hi Caner,
         Thanks for the advice. I've tried your way by building
ncurses-native separately but unfortunately it still breaks at the
same task and with the same error message, executing do_configure.
Searching at the internet I've found a web page (http://
tinderbox.openembedded.net/packages/ncurses-native/)were there are
reports of ncurses builds for OE, and for this version of ncurses
(ncurses-native-5.4-r19) the build report say that it failed for
do_configure. Could it be a problem with this particular revision?.
Should I install bitbake instead of runing it directly?

Thanks,
Alex.