Problems installing Ubuntu on Beaglebone - Looking for a clue on what i've done wrong.

I’ve made a real honest effort to get ubuntu running on the beaglebone, and i’m now suffering from a flat head from all the banging on the table. I’m sure that i’ve probably mis-interpreted what seem like very clear instructions in some way… I’ve tryed downloading several differnet images and get the same results, and i see that other people have been able to use these images, so i’m sure i’ve done somethign wrong.

I have been able to copy the angstrom disto back onto the beagle, and update it, using the same sd-card, and hardware… I’ve also tryed the process on a 2nd beagle bone and differnet card, and get the same result… I’ve tryed powering the beaglebone from both the USB port and the 5V port and it does’nt seem to make much difference.

Here is what i have done;

(1) From my Ubuntu Desktop

(a) got the image via wget ( )
(b) unpacked it
© used the script to copy the packages to the sd-card

sudo ./ --mmc /dev/sdd --uboot bone ( my sdcard finds its way to /dev/sdd )

I end up with a card that has two partitions on it, that looks like its ok.

(2) Pop the card into the beaglebone, and start up… connect to its serial port and monitor… it starts to boot up, i can see a whole bunch of messages fly past… it eventually gets to this point and stops.

[ 2.468780] mmc0: new high speed SDHC card at address 1234
[ 2.486785] mmcblk0: mmc0:1234 SA04G 3.63 GiB
[ 2.502044] mmcblk0: p1 p2
[ 2.569732] udevd[67]: starting version 175
Begin: Loading essential drivers … done.
Begin: Running /scripts/init-premount … done.
Begin: Mounting root file system … Begin: Running /scripts/local-top … done.
[ 3.060821] gadget: high-speed config #1: CDC Ethernet (ECM)
Begin: Running /scripts/local-premount … hwclock: select() to /dev/rtc0 to wait for clock tick timed out: No such file or directory
[ 8.914215] EXT4-fs (mmcblk0p2): mounted filesystem with ordered data mode. Opts: (null)
Begin: Running /scripts/local-bottom … done.
Begin: Running /scripts/init-bottom … done.

There is no output at the console, for about 2 minutes, and then i start getting messages displaying periodically that look like

[ 240.742889] r5:cf837ac4 r4:7fffffff
[ 240.746643] [] (wait_for_common+0x0/0x158) from [] (wait_for_completion+0x18/0x1c)
[ 240.756408] r8:00000400 r7:00000000 r6:cec84140 r5:00000001 r4:cedd1400
[ 240.763458] [] (wait_for_completion+0x0/0x1c) from [] (flush_work+0x30/0x3c)
[ 240.772705] [] (flush_work+0x0/0x3c) from [] (tty_flush_to_ldisc+0x14/0x18)
[ 240.781799] [] (tty_flush_to_ldisc+0x0/0x18) from [] (n_tty_poll+0x7c/0x178)
[ 240.791015] [] (n_tty_poll+0x0/0x178) from [] (tty_poll+0x68/0x8c)
[ 240.799285] r7:00000000 r6:ced91c00 r5:cedd1400 r4:cec84140
[ 240.805267] [] (tty_poll+0x0/0x8c) from [] (do_select+0x2b8/0x488)
[ 240.813568] r7:00000000 r6:00000002 r5:cf837e20 r4:00000010
[ 240.819519] [] (do_select+0x0/0x488) from [] (core_sys_select+0x22c/0x33c)
[ 240.828552] [] (core_sys_select+0x0/0x33c) from [] (sys_select+0xdc/0x10c)
[ 240.837585] [] (sys_select+0x0/0x10c) from [] (ret_fast_syscall+0x0/0x30)

It will display these messsages for ever and never gets to a login prompt… I am not running it with the ethernet port connected.

FYI. the beaglebone i a Rev.A5A, SN 1912BB000086

I am hoping there is a kind person out there who might be able to point me in the right direction.

I have tryed several different images, and i’ve also tryed some debian images, and they all give me the same result…

Kind regards

It appears that your image is OK.

I don’t use the serial port so I can’t comment on the messages you should see. I connect the BeagleBone to ethernet, then use ssh to connect to the BeagleBone. When the board comes up it will use DHCP to get an IP address from your router. My router lets me see the DHCP Client Table, so that’s where I found the IP address (It also shows the MAC address, so to make sure it always gets the same IP, I set a “Static DHCP” assignment, but it’s not necessary to do that and not all router allow it).

Then you just connect to the BeagleBone IP via SSH (or use PuTTY from a windows machine) and login as “ubuntu” with password “temppwd”.


Unforuantly, having it plugged in to the ethernet doesn’t make much difference, it still stops when it goes to run /scripts/init-bottom… The theres no dhcp request either on the network…

I’ve used that same image with the same install procedure on an A6 BeagleBone, and it works fine.

So I think the possibilities are:

  1. something wrong with your SD card… I have 1 card out of 4 brand new cards that appeared to program OK, but didnt’ work right when it ran. In my case it booted OK, but crashed when I tried to update. Same image on other identical SD cards works fine. Try another SD card.
  2. something wrong with writing the image to the SD card… not likely, since you’ve successfully written an angstrom image… I would think if the /dev was wrong the install script would complain.
  3. some incompatibility between Ubuntu and revision A5A BeagleBone… also not likely, if that were the case other people would have reported it.

If you have any peripherals connected (USB, capes, etc) disconnect them… just use power and Ethernet


The sd-card I’m using is the kingston one that came with the beagle. I have two beagles and two sf-cards, and i get the exact same results with both setups.

I’ve also tried a number of other images, and get similar results… So i’m guessing its not the image.

I might go and get a new sd-card and see if that makes a difference.

Looks like you’re not the first one to hit this problem, it’s been reported in the past as a kernel bug related to DMA:!msg/beagleboard/_cOkukIIVvE/pTRpWPuU8IIJ

I can’t explain why it would affect your boards but not mine, maybe some subtle difference between production lots of the chips. You might want to report the problem to RobertCNelson. The next Beagle Ubuntu release is supposed to have a much newer kernel, so maybe that will help.


Thanks kevin for that, i’d searched high and low and not seen this one… This sort of thing always kicks me.

You might still want to try a different SD card; since these kinds of problems can be timing related, a faster card may behave differently. I’m using SanDisk SDSDQU-016G ($14.99 on Amazon).

It certainly won’t hurt to have a couple more SD-cards around…

Got a new memory card. ( Name brand San Disk. ) same problem…

How are you guys powering the board? if via usb/otg... Please retest
with a 5Volt DC power supply..


Thanks Robert for this suggestion.

I'm powering it via the 5V PSU, as i had seen this can be problematic.. its good for 2A and i put the scope on it, and its not sagging or got any noise on it.

FYI, The new Sdcard with angstrom image runs fine as well...


Since it’s not the power supply or the Beaglebone itself (Anstrom runs OK), the next most likely culprit is the SD card writer.

When you say that the new sdcard with angstrom image runs fine, do you mean that you wrote the Angstrom image onto an SD card, and that works fine? Assuming you used the same Linux PC and same SD card writer, that would probably rule the card writer out as the cause.

Perhaps something is going wrong when you run ./ It looks like you’ve got all of the command options right. Could you post the output you get from the script when it builds the SD card image?


I have to say that I have been having the same issues, I’ve tried the SD card that came with the bone, a sandisk, some random micro center card, it just freezes after /scripts/init-bottom. Using a 5V supply. Can supply 4A, so that shouldn’t be the issue.

Since it’s not the power supply or the Beaglebone itself (Anstrom runs OK), the next most likely culprit is the SD card writer.

I guess that is a possibility.

When you say that the new sdcard with angstrom image runs fine, do you mean that you wrote the Angstrom image onto an SD card, and that works fine?

Yes. On both the new and old sd-cards the angstrom runs just fine… I wrote the debian image, tested, then wrote the Angstrom image, then tested ( and it worked ) and then wrote the debian images back again…

Assuming you used the same Linux PC and same SD card writer, that would probably rule the card writer out as the cause.

Yes, identical setup…

parallels@parallels-Parallels-Virtual-Platform:~/ubuntu-raring-snapshot-minimal-2012-11-29$ sudo ./ --mmc /dev/sde --uboot bone

I see…
fdisk -l:
Disk /dev/sda: 68.7 GB, 68719476736 bytes
Disk /dev/sde: 3904 MB, 3904897024 bytes

/dev/sda1 on / type ext4 (rw,errors=remount-ro)
devpts on /dev/pts type devpts (rw,noexec,nosuid,gid=5,mode=0620)
/dev/sdd2 on /tmp/tmp.sIdukdUW6I/disk type ext4 (rw)
/dev/sde1 on /media/21DC-F818 type vfat (rw,nosuid,nodev,uid=1000,gid=1000,shortname=mixed,dmask=0077,utf8=1,showexec,flush,uhelper=udisks)

Are you 100% sure, on selecting [/dev/sde] (y/n)? y

Debug: image has bone kernel support: v3.2.33-psp26
Debug: image has omap kernel support: v3.6.8-x4
Debug: image has panda 3.2 kernel support: v3.2.34-x15
Debug: ARM rootfs: armhf-rootfs-201211292150.tar
Debug: image has initrd.img:
Debug: image has device tree:
Debug: fdisk version:
fdisk (util-linux 2.20.1)

Downloading Device’s Bootloader

Umm ^^^ that's not just Ubuntu Desktop, that's an Ubuntu Desktop on
top of Parallels... Mac I'm guessing?

Any chance can you boot into a debian/ubuntu livecd..

As that setup is definitely not tested...


Yes, you are correct. Do you think that could be problematic? Though the same setup writes the angrostum system just fine.

I do have native debian machine in the workshop that i'll try out. It would be odd if this is the case, as the vitalisation platform should be transparent.. ( but its worth giving it a shot )

It would be worth a try, as my script uses a bunch of userspace tools
to touch /dev/sdX to tweak the image for the final target, whereas the
Angstrom image just requires 'dd' to /dev/sdX...

So it looks like something is getting corrupted.. As the image works
fine on my A2/A3/A6 BeagleBone's...


I now have a working unbuntu image running on the beaglebone.. But not quite in the way you've described.. In pursuing various avenues of making this work, i had discussed this with a friend who also has an A5 and had used your scripts successfully.

He sent me an image of his one, ( just after you sent your message )
( copied using dd ) and i copied that onto my sd-card. and it works nicely..

So it seems pretty likely hat there is something weird going on with the way in which the build script is behaving in my environment…

Thanks for your help so far, i'd be lost without it.

Well, that's good news that it works now.

So, to help the next person, do you know if there is anything we can
use to detect this "parallal's" environment, so that the script can
print a warning or possibly just not run...