Problems installing WSPR and RTL-SDR on Beaglebone Debian


After trying Angstrom, Ubuntu, Debian, Angstrom I decided to install Debian on the emmc. No problem. FLdigi and several other amateur radio programs are running fine. The main reason for the BBB was a WSPR monitor. So I got the sources installed the depending libraries, made configure and everything went well: “creating Makefile, … Installing: …”, but in the directory was no “make” file. Same problem with RTL-SDR, configuration went without complaints, but no make file. I can’t open the py-file due to missing files.
I ran this also as root and both sources compile fine on other machines.

Debian wheezy 7.4 / 3.8.13-bone40 / Xfce.

Any pointers?

Thanks in advance for your help.

73 de Hajo

Oh Dear,

problem solved. “make” was not part of the Debian distribution. I had to install it by hand.I think nobody seems to compile programs anymore.


The official debian image have gcc/make installed by default.

With my other traditional images on the only goal was enough packages
to "get online" to use apt-get...


Hello Robert,

I was using the “official” image “BBB-eMMc-flasher-debian-7.4-2014-02-16-2gb.img”. While installing make with apt-get it was installed new. I couldn’t recall the message… too many lines gone by.

Program still doesn’t work but that’s another problem :wink:

Anyway thanks for the answer.