Problems with CAN in BBB

I am working with a BeagleBone Black rev C for a project using CAN. I am using the CBB-Serial-r02 cape because we need the UART features too. The problem is that CAN is not working. I did a lot of things to test it on a 3.8-rt kernel from RobertCNelson (which is only PREEMPT), but it didn’t worked at all. Some things that I did:

  1. Installed the latest Debian Image
  2. Always modprobe the can modules (can, can-dev, can-raw)
  3. Compiled and installed canutils, always using the “cangen can0” to test the can output
  4. Always run “ip link set can0 up type can bitrate 125000; ifconfig can0 up” to activate can0
  5. Installed the CBB-Serial-r02 dtbs from the official repository, even that the debian image that I used already includes it
  6. Test the output with an osciloscope. I did the same test with an EzDSP 28335 and it worked, so it is not a problem with this part of the method
  7. I tried to do a candump can0 with the DSP generating random data, but the candump didn’t show any data

I recompiled 3.14 kernel using the dtb-rebuilder (instructions on this tutorial: https://groups.google.com/d/msg/beagleboard/_9u1B6ZkgCU/K2ARgwfC490J) and enabling the DCAN1 (because DCAN0 disables the I2C used for capemgr) and it didn’t worked too.

Well, I ran out of options here. Some one is having problems with the rev C and CAN too or that is some problem with my method?

Do you have a line dtb=am335x-boneblack-can1.dtb in uEnv.txt?
That was a problem for me, I am working on a project with almost the same setup.

Aaron

That shouldnt apply to the logic supply serial cape. It has an eeprom, and uses a different device tree blob. Which is included with every beagleboard debian image I’ve tested so far . . .

Hey Bruno,

regarding your Step 3) Try “ip link set can0 up type can bitrate 125000 listen-only off”.
After this Step send some CAN Messages to the Controller and enter ifconfig in the console window. Please tell me, if you can see the can0 device. Did the device read any messages (RX entry)

Kind regards,
Michael

I don’t know… I use the capemgr and it is loading the cape (or, at least, is what the dmesg log is showing). This dtb is already on the BBB images or I have to use some tool to generate it?

Hi… I tried it and I posted the logs here: https://groups.google.com/forum/#!category-topic/beagleboard/n5lkTW8R3Xo

Probably I have some issue with the candump thing