Problems with USB EHCI

(Sorry if this message shows up twice. I sent it before subscribing, and
unsurprisingly that one never appeared)

My new revC Beagle Board has problems with USB EHCI. At this point I'm
fairly convinced that it's a problem with the board, but just in case
I'd like to see if anybody on this list can help out.

In short, when I boot with a USB device plugged in, I get this message:

hub 1-0:1.0: unable to enumerate USB device on port 2

For a while it would extremely sporadically discover the device and then
lose it almost immediately, but now this is all I get. I'm using
Angstrom, and also tried the ramdisk provided with the rev C validation

I've tried numerous configurations:

Kernels: 2.6.27, 2.6.28, several self-built revisions of 2.6.29 over the
last few days (built out of the openembedded git), and the rev C
validation uImage.
USB devices: (All devices listed have been verified high-speed USB 2.0
devices by testing on my desktop) a non-self-powered USB hub, a 2GB
memory stick, and two different wifi dongles.
Power supplies: Via USB from my desktop, laptop, and a powered USB hub
not connected to any computer, and now with a plenty-powerful 5V 2A AC
adapter (the very one that was powering the USB hub, I guess it's no
coincidence that it's a regulated 5V adapter X-D).
Bootloader: I've tried with the u-boot that came preinstalled, the
u-boot from Angstrom, and the rev C validation u-boot (which seems to be
the same as the one that came preinstalled)

Is there any chance at all that this is not a board issue?

- Gregor Richards