Process Dies after 5 mins

Hello Guys

I am using a BEaglebone BLack with Debian.

I added a service to startup using update-rc.d myprogram defaults.

the program starts at startup but it is killed automatically after 5 mins.

How can i keep it alive forever? I dont want it to die.

Regards,

Kevin

Restart it upon death with e cron job ?

what program and why is it exiting ?

Just a shot in the dark:

Is it possible, that the process in question is writing a hidden
temporary on a tmpfs-filesystem, which returns "no space left
on device" after 5 mins of writing to it and the application
does not handle that error very wel and dies.
Due to the missing "close" the file vanishes and
one can start the cycle again?

...?...

HTH!
Meino

evilwulfie <evilwulfie@gmail.com> [14-12-14 19:36]:

nono
the process just does UART work up and down (transferring data between UARTS).

If i keep the process open in a terminal it runs indefinitley.
if i run it under the init.d after 5mins it goes off.

no blocking calls, no file io.

is there a way to spawn the process via systemd and keep WATCHDOG=1 somehow…

Hi,

then the process is missing a controling terminal.
Try to start it with nohup from the script to verify that.

Kevin D'Souza <kevin.dsouza3691@gmail.com> [14-12-14 20:28]:

nohup ./myprocess

i put this in a .sh and ran it via init.d

it doenst spawn the service. >.<

ok so i updated rc.local inside /etc

added

nohup /pathtomyprogram/program &

exit 0

works well.

the & Plays an important role and also the /path has to be the custom path and not inside /etc i was trying that before. now i just moved it outside.

THanks Guys!.

CHeers!

nohup /pathtomyprogram/program &

/pathtomyprogram/program & Probably would have worked without nohup. & terminating a command will run the “process” in the background, e.g. a subshell. nohup is used for keeping processes from exiting after a terminal logout. e.g. it catches the “hangup” signal, and ignores it.

http://linux.die.net/man/1/nohup