prolific serial adpater only work if BBB is powered by computer

Hi all,

So i have a bealge bone black with a 4.3 LCD cape running on debian. I also have a usb hub with 4 output. I currently use 3 of these output (wifi dongle, usb key and a prolific usb to DB9 serial adapter).

The serial adapter is here to read some values from an industrial scale.

Here is the problem. if the BBB is connected to a computer via the mini usb port, everything run well. (with an without a 2.5 amp on the power barrel.)

The second that i disconnect the BBB from the computer, the serial adapter will only receive 0xff caracter. Iv’e tried on others computer with DB9 connector to exclude the scale from the equation.

I have no clue and I can’t leave a computer connecter to the BBB just to get the serial adapter happy…

ps. I have 3 different serial adapter and same result for all. Also 3 different usb hub.

Thanks in advance



You are probably trying to draw too much power through the USB port from the BBB.
I would try the same setup, but using a Powered USB Hub. See if any of your hubs have a
wall-wart accessory that can power the hub directly, and take the power load for
all the USB devices away from the BBB.

— Graham

I forgot to mention that the usb hub is powered by a 2.5 amp power supply

Do you have a terminal plugged into the command line serial port?

What does it say is happening?

— Graham